Roughness map disappearing when looking down

Have recently gotten back into UE4, and there are ofcourse quite a few questions and some confusion going on. Haven’t been bothered with anything worthy of reaching out for help with untill now though.

Basically, when I look down on my floor material, the roughness disappears. If I have the camera tilted to “ground level” (looking straight forward), the roughness is there… But as I tilt the camera down, it disappears as a vignette around the screen.

I’m not sure if this happens to other materials as well, but it’s very obvious on the floor.

First: Camera looking forward. Everything looks OK

Then, looking down. Roughness (gradually) disappears

So, what gives?

Also, why is everything so **** shiny in UE4? Can you tune down the bloom and the shiny areas globally somehow? Thanks :slight_smile:

Have you placed reflection capture actors in the level?

Okay… So I had no idea there even was such a thing :smiley: Placed a box reflection capture in the scene and it looks a lot better.

However, the (kind of) same problem is still there; the roughness changes based on camera angle. When I look forward, the floor is much shinier than when I look slightly more towards it.

Looking forward: Darker and shinier floor.

Looking slightly downward: Correct roughness “fades in”

This is exactly like before, only that the roughness now displays properly where before it would not display at all. Only know I could notice that when the roughness was displaying before, it was doing so incorrectly.

Am I being too confusing or do you understand? Thanks

What’s your material look like? What do you have plugged into the Specular and Metallic outputs?

Material for floor, super basic:

Textures are made in Substance Painter. Everything is put in the right place

Here is the Metallic:

As you can see there is no Specular… Should there be one? Didn’t Roughness/Metallic replace specular with PBR?

You are mixing material and light terms. Roughness is totally independant of view angle. You can visualize every material paramater using Buffer Visualization.(under LIT).
I guess that artefact that you are seeing is related to screen space reflection. Could you try to turn that off?

That did it! I made a post process volume and turned the intensity off screen space reflection down, and now the shininess is consistent.

Is there some global post process settings available? Or must I use this volume over my entire scene?

Thanks a lot for the help! :slight_smile:

You can make post process as Unbounded. You could also try to set screenspace reflection quality to higher. That could fix those artefacts too.

That’s actually what I did. Lowered intensity to 50 and upped quality to 100. When fully removed it became obvious why it’s there in the first place… Looks wrong without it completely :slight_smile: