Root motion does not apply

As far as I remember, the character movement component takes care that the character is always on the ground. That’s why your character won’t lift off. I think the usual solution is to create an animation triggered event and set the character to flying.


Most of my animations have no root motion (walking, running, etc), but I want to use Root Motion feature for my ‘jump’ animation. I turned “Enable root motion” on in animation asset and changed “Root motion mode” to “Root motion from everything” in Animation Blueprint, but it didn’t work properly - actor didn’t move, and the animation looked like in “force root lock” mode.

Do I need to manually apply extracted root motion? I couldn’t find any tutorial showing how to do so.

How can I make my actor actually jump with the animation using Root Motion?
(I’m using c++ with blueprints.)

I’m not using character movement component tho - my character class inherits only a pawn class, and I didn’t write any gravity logics yet.

Okay, but I think only the character movement component supports root motion so far. When you want root motion to be applied to a pawn, I would guess you need to implement a custom movement component which reads the root motion out of the animation instance used by the skeletal mesh. A quick lookup in the docs gave me UAnimInstance::ConsumeExtractedRootMotion, perhaps that already sufficient.

Thanks, that makes sense!
Do you know any tutorial, or some good descriptions about implementing it?
I’d depend on documentation, but, to be honest, it’s really poor.

Unfortunately I don’t have any resource on this :frowning: But when I wanted to implement such movement component, I would look into the CharacterMovementComponent source and search for “rootmotion” :wink: You could also search for “FRootMotionMovementParams”, which seems to be the bridge between anim instance and character movement comp.

Alright, thanks for help

Actually, where do I find the source of CharacterMovementComponent?

I’m using UE4.15 and I no longer see the Root Motion category in the individual animation assets. I know there was a large Animation update in 4.15, do I not need to select that checkbox anymore?

Thanks so much

This video will get you there :slight_smile:

4.18 i can’t find “Root Motion Mode” as well! “EnableRootMotion” can be find under the animation itself.