Download

roof not white as the wall, why?

Hi

So I have the same material on my walls as on my roof. all are static mesh , unwrap the same way, exported the same way. Lightmap is at 512. Still why is my roof so much darker, its yellow and my walls are white. Why isnt the roof white aswell?

The only light I have is the sun directional light and a SkyLight to fill the scene with some over all light.

IF I look straight at the roof, 90degree UP it slowly turns whiter. Not 100% white but abit brighter. Is it because SkyLight doesnt lighten up the roof properly ?

I do guess I will need more light in my scene but still, why are the walls good enough and not the roof…

e3da2a6ef972081a8450d9049e7089edd7d4f320.jpeg

Any tips and tricks ?
Thanks

Have you built lighting yet? Also, are you using Dynamic or Static Lighting?

hmm replying again. first time didnt work.

Yes the light is built. The DirectionalSunlight is Static and the Skylight is set to Stationary.

Try to disable eye adaption. Go into your post process volume and set the Min Brightness to 10 (max) and the Max Brightness to around 0.58 After that build the light :slight_smile:

Could you also post your material setup?

What are you using for your ambient light? A skylight or the Environemnt color in Lightmass?

The Skylight defaults to having a black lower half, making faces the point straight down have a much darker color than those facing other directions.
Also, the grass and floor textures are very dark and will absorb much of the light bounced off it.

aah yeah using the Skylight and its only problem with the roo (faces pointing downwards) is there a way to tell to stop doing that :stuck_out_tongue: OR is there an option to make the light bounce more time ?

Or will I just have to put in point lights to make the roof brighten up. Because I like the overall light its just the roof…

You can set the “Lower Hemisphere is Black” toggle to off, but I’ve found that it can make dynamic objects and other objects look too bright.
You can increase the number of bounces in your World Settings>Lightmass settings, and that will brighten it up, but the real issue, I think is the super-dark floor. You can either lighten that up, or do a Lightmass Replace for your Base Color in your shader:

Basically, it defines what gets sent to Lightmass/swarm to render and what gets rendered in the viewport. So, you can put white in place of your diffuse map and you’ll get a much brighter bounce.

Ahh lower Hemisphere unchecked helped perfectly! So thanks :smiley: