Right-Click Menu / Tool Bar Menu Disappearing?

Hi all,

So, I’ve had a few issues with 4.25, usually just seemingly random crashes but today has brought something new which is incredibly frustrating.

For some reason, after a period of time (or potential action that I’ve not identified yet), the right-click/context menu operation within a Blueprint starts behaving oddly. It will open and then close instantly. The same is happening with the main toolbar menu across the top of the window, File / Edit / Asset / View etc… I can click on File and the menu appears briefly and then closes again.

The only work-around so far is to close UE4 and re-open it, which, as you can imagine, kinda kills the flow.

Has anyone else experienced this? If so, did you find a solution?

I wondered if it might be because when I type my left thumb hovers over/touches the touch pad on my laptop, but I have that actually disabled, so I dont think its related. There is a finger print scanner on that touchpad, but I’ve not had these problems before and had the laptop for about a year.

Hugely frustrating.

Any help would be enormously appreciated :slight_smile:

8 Likes

No one else experienced/experiencing this / have any thoughts… :o/

I can subsequently confirm that it isn’t project related as it is occurring in two separate projects at this time.

1 Like

I’m hitting the same exact problem (4.26). Suddenly, any dropdown menu starts disappearing as soon as it opens. I also haven’t found a work around other than to restart the editor. Dunno if it matters, but I run the editor as administrator.

1 Like

Hey @oatssss, thanks for the reply. Sorry to hear you’re having the same problem also.

Has this recently started for you, or have you experienced it for some time?

I’d not used UE4 for about 4 weeks, and in that time I had bought of a couple of extra monitors, so using my laptop as well etc, multiple screens - unrelated to UE4 but I’ve encountered some other oddities with Windows 10 and multiple screens.

Not sure if there’s any similarities in our setups?

This said, last night it happened when I was only using the laptop, no other screens plugged in, so doubt its the cause.

I have 4.22 installed also, I might try messing with an old project and see if it occurs in that version also - if it does - it might imply more of a system issue than a specific UE4 one.

One thing that also happened last night, which I noticed as it occurred, was that there was a really rapid flickering of the context menu, on/off, on/off, on/off etc… at the top of the screen there was a little “saving” prompt, presumably from Auto-Save etc. Again, might not be releated, just I’m not finding many specific events that seem to be triggering it at the moment.

If you have any other thoughts, or find anything that might help I’m all ears, and likewise, I’ll share anything I find. :slight_smile:

1 Like

Noticed the issue in another area this evening.

I was right-clicking on a sprite and the context menu disappeared, and then started creating just a black menu, with no writing to see.

Things I tried;

Resizing the window from full screen to a randomly smaller size. This worked - once, but then when I made it larger again it started failing again.

I also changed the desktop resolution from 1920x1080 to 1600x900, then chose to revert on the Windows prompt. This made no difference. (this had previously fixed an issue where the top of various application windows became a black/white bar).

Now, here’s the third thing I tried, which interesting, DOES work…

As I had my other monitors plugged in I moved the now slightly smaller UE4 window to one of those other screens. Right-clicked - everything worked perfectly. I resized it to full screen and it still worked perfectly.

So - in my specific case, it looks like having Windows using multiple monitors maybe the issue - which was the only change I had made in the last month or so, previously I was only using the one display on the laptop.

What’s a bit odd about this though is that last night I was using the laptop without those other screens plugged in, and I experience the problem. So I dont think its related to having them plugged in, but perhaps related in some way to have a multi-screen setup?

@oatsss, can you confirm whether you have multiple screens also?

Incidentally, moving the window back from the other monitor to the main laptop display instantly recreated the issue again.

sigh

2 Likes

Thanks for the info @RobMeade! Yes I think it would be a good idea to try and find some similarities between our setups. The issue also happens on all projects for me. I haven’t been using Unreal for long, so I suspect my setup was always prone to the defect. I’m running from a laptop (rtx 2060) that’s connected to an ultra-wide monitor (2560x1080). I disable the laptop screen and only use the monitor. The next time this happens, I’ll try some of the workarounds you suggest.

Edit: I just hit the issue again. When I move the editor back to the laptop screen it works fine. I also get black screen flashes in MS Edge just like @shubyyy_yg

1 Like

I also have been running into this issue as well for the past month on both 4.26 and 4.26.1. Whenever the right click issue occurs, I get black screen flashes on chrome as well for some weird reason. The only fix I’ve found for this issue is reverting my Nvidia Game Ready drivers back to the December version.

1 Like

Hey @Oatssss, interesting, we both have the same graphics card, and both have multiple displays. Definitely a factor I think.

In my searches today I found some information that suggested the latest NVidia driver was at fault. I’m not 100% convinced about this, as I don’t quite understand how it would be ok on the external monitor but not on the built in one. Same graphics card. Same drivers etc.

That said, there’s a reply further down from @shubyyy_yg who mentions that they also rolled back the driver and had success.

For reference, I rolled back just one certified version which was the earlier on in January, it seemed ok at first, and then started to go wrong again. As such, I will try the December 2020 driver which @shubyy_yg mentioned they used. This corresponds with the other article I saw that mentioned the same version etc.

Hoping this helps you too! :slight_smile:

1 Like

Hi @shubyyy_yg, thanks for the reply and info. I think I also experienced an occasional issue with Chrome but I assumed that was the hardware acceleration issue that sometimes occurs. I disabled it and didn’t see any issus with Chrome after, but UE4 is still mis-behaving.

I downloaded one version back from NVidia, it was the earlist certified version released in January this year, but its not worked, so I’ll give the December 2020 version a go as its worked for you.

Thanks again for the update, hopefully this will help @Oatssss also. :slight_smile:

1 Like

In GeForce Experience, I switched to the studio driver (as opposed to the game driver) and haven’t had the problem since.

1 Like

Hi @Oatssss, I used the gaming driver, but the older one from December and am obviously now stuck a little in limbo not knowing when I’ll be able to update the driver without having the issue again, but still, it does seem to be working normally again!

Another weird issue I was having outside of Unreal Engine was that sometimes the top of the application windows (Word / Chrome etc) would turn into a solid white rectangle, no icons, no menus etc… this happened a little while before the Unreal Engine issue, but interestingly I’ve not had that happen at all since rolling the driver back too. Seemed to be related to multiple displays and having the window maximised, didn’t occur under any other circumstances.

All good for now though :slight_smile:

1 Like

Spoke too soon, I still encounter the issue, but much less frequently. I’ll try rolling back as well.

1 Like

I had this same issue with 4.26.1 using Jan/Feb/Mar drivers for the GeForce 2080. Rolling back to December drivers has fixed the issue as others have mentioned.

2 Likes

Sorry to hear you’ve had the same issue. Frustrating to be held back on the drivers like this. :frowning:

This issue is driving me nuts and I would really like to fix it, but for casual/hobby developers like me who game on the same rig they create with, rolling back their drivers three whole months is just not a palatable solution. If this issue is indeed something on NVIDIA’s side, is there any indication that Epic and NVIDIA are even aware of it?

1 Like

I believe it is entirely nvidia since I had similar issues with both Edge and Chrome which have now also been resolved by rolling back.

I think I’d have to agree. I haven’t experienced the “white bar” across the top of apps like Word when they were full screened since rolling back to the December driver, and Unreal has been behaving itself. So yeah, guess its the driver.

Bit annoying as the only way to test is to potentially take a risk and screw things up again… sigh…

I have exactly the same issue as you guys - this is driving my nuts as I have to randomly restart UE4 every idk 15 - 20 mins of work ? That’s a total killer ! I tried everything and nothing really works.

Sorry to hear you are having this problem too. Have you tried what we have all done, e.g uninstalling the NVidia driver and then installing the last one from December 2020? It seems to be the common “fix” for everyone so far.

I have the exact same issue in UE4.25 and 4.26. No idea why its doing this but its frustrating. I thought there might be a software/driver conflict (normally with Asus Drivers and EVGA Drivers) but it doesnt make a difference.