Right-Click Launch(uproject) - render quality?

In 4.8 my ‘Engine Scalability Settings’ were set to EPIC and ‘Monitor Editor Performance’ is unchecked.

The render quality of PIE was EPIC.

The render quality of Play->New Editor Window was EPIC.

The render quality of Play->Standalone Game was EPIC.

The render quality of R-Click->Launch Game was EPIC.

I then open the 4.8 project in 4.10 and re-save everything, close editor and reopen project.

‘Engine Scalability Settings’ are again set to EPIC and ‘Monitor Editor Performance’ is unchecked.

The render quality of PIE is EPIC.

The render quality of Play->New Editor Window is EPIC.


The render quality of Play->Standalone Game is MED(ish)

The render quality of R-Click->Launch Game is MED(ish)

There is obvious anti-aliasing on straight edges and the viewport res looks like 720p even though
Editor->Preferences->Play has all window sizes set to 1920 x 1080.

Where/what can I reset so that R-Click->Launch gives me the same EPIC quality like I had in 4.8?

I’d rather set a global ini file rather than use console commands in a blueprint.

Hey ash22,

Could you provide me comparitive screenshots of the Med(ish) settings versus the Epic settings for the project you are reporting this issue with?

I am currently in the process of testing this issue, and definitely discovered the Project Settings ignoring the window sizes when launching using the Right-click. I will return with more information once I have tested this issue in greater depth.

Thank you,

Here you go.
It appears to me that RightClick->Launch and Play->Standalone Game ignore the EPIC settings and use some other defualt MED setting regardless, resulting in MED quality. (Fyi I have an NVIDIA GTX 670).

So adjusting settings under Editor Preferences, which only affects editor sessions. You are going to need to edit the Scalability settings in your projects Scalability.ini located in your Unreal Projects\ProjectName\Saved\Config\Windows.

What I did was copy the final settings for each section from my BaseScalability.ini (which are the highest quality settings). You can find this .ini in the EpicGames\4.10\Engine\Config directory. Below is an image of what I am referring to…

You will need to make similar changes to all of the .ini files that control the options you are attempting to change. I would also open the BaseEditorPerProjectUserSettings.ini and take a read over the information in there as it has the information you need on how to get your settings transferred over correctly.

You might also find these links helpful as well.

Scalability Reference

Let me know if you are not able to get this to work, and we can continue to troubleshoot.

Thank you,

Thanks Andrew.

"You are going to need to edit the Scalability settings in your projects Scalability.ini"

Does this mean I have to apply this procedure for every single new project?

I thought (was hoping) I could just tweak some file settings once-only in the base UEengine ini files and they would apply globally to all projects (I never had to do any kind of ini file tweaks before).

"You will need to make similar changes to all of the .ini files that control the options you are attempting to change…"

Yes, the issues are not just AA and shadows. AO is not enabled and my screen also looks like it is rendering at 720p instead of 1080p. There are probably other low quality settings that I have yet to notice. However, I don’t want to start having to tweak loads of ini files just to get the quality back :frowning:

Can I assume these ini file tweaks are just a workaround until you resolve the real underlying issue?

If so, I’d prefer to stop using RightClick->Launch and Play->Standalone Game and wait for a global fix rather than having to constantly edit project ini files.

I am not experiencing the same drop in quality settings that you are reporting for your own project when right-clicking and selecting ‘Launch Game’ nor in my Standalone.

I have entered a bug report (UE-24719) in any case, as I have not been able to successfully override the ‘Launch Game’ quality settings. I know this is possible through blueprints, but there should also clear instructions on how to effect the launch game from the right click menu as well.

Would you mind testing to see if you get this same drop in quality in one of our default template projects?

I attempted to edit a few different .ini files, and none were providing me with the expected results. Perhaps I am entered the incorrect console variables at the wrong locations, but I attempted the sg. quality overrides as well as the r. rendering console commands.

Once this bug has been addressed I will update you with further information. Thank you for taking the time to report this issue.


"Would you mind testing to see if you get this same drop in quality in one of our default template projects?"

I created new default template 1st and 3rd person projects and in both cases the quality is perfect and consistent across PIE, New Window, Standalone and Rclick->Launch.

That potentially hints at one of the following issues:

ini files created by UE4.10 projects are somehow interpreted differently than ini files created for < 4.10 projects, that are carried forward (migrated/upgraded) to 4.10.

Something I added to my project is breaking quality.
I have (at some point over the last few weeks) enabled DFAO, LPV, DistFieldSoftShadows, ScreenSpace reflections etc, etc.

Any one of the above may (or not) have adversely affected my render quality in different viewport modes as new template projects don’t have any fancy settings enabled by default.

I will create a temp/debug copy of my project and start removing features/options/settings to see if I can track down the issue.

If I get back to a basic scene with default settings and the problem still exists then it may possibly point to an ini file issue.

It will take some time, but I’ll let you know my conclusion.

Here is an isolated test project:


If you run the test project and the scene is the same high quality in

  • PIE->New Editor Window

  • Editor->Standalone Game and

  • RClick->Launch

…then something about my UE4.10 installation (ini files?) is probably amiss.

If you are unable to override Launch Game quality settings it may be symptomatic of my issue. My Launch / Standalone Game quality just happens to be stuck on LOW for some reason. Fortunately, packaged exes are fine and the expected EPIC quality.

Anyway, It isn’t hindering my development, so hopefully you’ll track down the issue in due course. When I get a chance I’ll reinstall 4.10 (or the next version) to see if it resolves anything.

I may have resolved the issue.
The quality seems to be back in order now.
(i.e. AO, shadows, reflections are working again).

Basically, I created a new 4.10 template project and migrated the map(level) of my current misbehaving (4.10) project into it. Prior to this I would normally open the 4.8 project in UE4.10 and re-save it. As such, there could have been legacy/junk ini-file parameters from 4.8 carried over and conflicting with 4.10.

I am still curious about the differences between the two project ini files.
The Engine/base/ini files have not changed, so the difference must be somewhere in the project’s Config folder.

Anyway, the quality is now consistent between PIE, Standalone Game and Rclick->Launch.