Right-click bugs and black screens in the Editor window

This type of bug has been occurring in the editor’s window in Unreal for some time now. Turning the unreal off and on will work again, but soon the same situation will be repeated. I’ve also verified and reinstalled the engine, but it doesn’t seem to be an internal problem because it’s happening the same way. When I recorded the screen with obs, I couldn’t see any problems on the recorded video. Turning off MFAA and G-sync from the nvidia control panel does not resolve it. What’s the problem?

I’m also having the same issue! Any update on this? Did you manage to fix it?

No…I updated to 4.26 from 4.25 but nothing changed

Yup exactly the same issue. @rntlpbm do you have a 4k and fullhd dual monitor setup? Do you have the 4k monitor at 125%?
My colleague as a dual 4k at 150% and doesn’t see the issue. As a side note, I only start to see this after updating to 4.26.1. 4.26.0 was fine.

Same issue here!

10850K, 3060 Ti, 32GB, 750W - No temperature on any component has surpassed mid 50 degrees during working in UE. Minimal background tasks. Tried both last Nvidia driver as well as the latest one. Default Nvidia Control Panel settings.

The black screen then extends to other open programs such as Chrome whilst this bug is in effect. Only treatment is to close Unreal Engine (and restart it, which grants another 20-30 minutes inside the engine). Every other program and game works fine for hours gaming or rendering, it’s just Unreal doing this. Can game on Cyberpunk, or render in Arnold for hours and nothing like this happens.

No, i’m using fhd 100% dual and also single(for 3rd monitor). It happens all the time, single or dual monitor

Any resolution to this issue yet?
I’ve been experiencing the exact same issue for more than a month now.
RTX 2070 laptop connected to an external monitor. I’ve tried more than one external monitor.

Any resolution to this issue yet?
I’ve been experiencing the exact same issue for more than a month now too

Have a look here: https://answers.unrealengine.com/questions/1012618/view.html

Lots of info, solutions; not all may be applicable, though. Things that works for some people, do not work for others. Worth checking out.

Hi,
I’m seeing this exact same issue on Windows 11. Currently running 4.27.1 and this only occurs on an extended monitor plugged into my laptop.

Yeah I’m having the exact same issue, this makes me so mad

Ok so I think I found a fix! on GeforceExpirience Switch from game ready driver to Studio ready driver and install it. Unreal worked fine for over an hour now!

Nah, I always use Studio Driver only and have same problem with 4.27.2 Any new ideas?

Any update on this? It’s very annoying.

Something to try, I found this on a Nvidia sight I think…
Right klick on screen… go to Nividia control panel… Change Resolution… At bottom click “Use NVIDIA Color Settings”… Desktop color depth = Highest, Output Color Depth= Highest… Output Color Format= RGB… Output Dynamic Range = FULL… Do All Monitors… RESTART MACHINE… You will probably find when you open the nvidia control panel some of these settings are off… It works for me with studio and game drivers… And if your like me you pulled all your hair out… well mine grew back… I hope this may help at least one person.

3 Likes

God bless you, you have a special place in heaven, this has been bugging me over a year now, finally fixed!