Rigged in mixamo and Unreal won't render texture propely

ive used magica voxel before but the UVs were never very good. you may want to check that and possibly bring your model into a modeling program to fix / re unwrap

Hey guys,I’m having some issues using mixamo and Unreal Engine.

I’ve created this character on Magica Voxel and I really want to animate it for my game.However,after I auto-rigged in mixamo and imported to Unreal Engine,it came up all messed up and isn’t what I’m looking for.

Here’s how it should be like:
(This is without rigging,just straight importing from Magica Voxel to Unreal)

And this happens after the auto-rig.

I’ve tested a lot of stuff but I have no clue why this is happening.Can anyone give me some help please?

Thank you very much.

Looks like the downloaded FBX is being triangulated and that is messing up the UVs.
Since its a simple model, any 3D software with auto UV would do.
Here is blender UV tutorial , this will do : https://www.youtube.com/watch?v=V6OXSR5Ynyc

Export FBX and import it in to UE4 and see if the problem persists.

ue4 triangulates all meshes. also though i agree the uvs are probably messed up, i wouldnt go for the auto unwrap since that will really screw up how things were layed out . for instance when unwrapping a cube most people would unwrap it into one island, whereas auto unwrap will probably seperate it into 6 separate islands. of course if its a simple texture of a solid color or you want to re texture it then have a ball and do it as you like. though im not sure the current texture is one solid color since the texture can look messed up in the first place.

on another note you may want to check the uv channel 2 which is the lightmap. if thats messed up then it could just be the way light is reacting to your model.

Thank you guys for the quick answer.

Here’s what I’ve tried:

1.Exported .obj from magica voxel → Done the uv mapping in blender → Exported .fbx from blender and uploaded to Mixamo → Imported .fbx to Unreal Engine.

2.Since the first one didn’t work I got the .fbx from Mixamo onto blender and did the uv mapping once again.

3.Exported .obj from voxel → Uploaded directly to Mixamo and exported .fbx → Imported to Unreal engine and this time it didn’t even had materials on the model.

4.Exported .obj from voxel → Uploaded to Mixamo and exported .fbx → Imported onto blender and noticed there were no textures nor materials.

5.Tried to upload both .mtl and .obj in a zip file to Mixamo but it says that it was unable to map my skeleton.

None of these attempts worked at all :frowning:

One thing I noticed is that the vertices in the model onto blender is kinda messed up.There are lots of triangles,especially in the areas where the uv map gets weird.Maybe that’s why it’s not working when I auto-rig?

Note that it still works fine without auto-rig.

Ok,so it turned out to be a mesh problem.

After hours and hours of testing,I was in blender when I decided to try to remove duplicate vertices.It turns out that it removed over a 1200 vertices.

Before removing duplicated vertices:

After removing the vertices(Just like the problem I’m getting at Unreal Engine):

So probably Mixamo or Unreal Engine are removing those duplicated vertices.

Thank you!

For anyone having this problem in the future,here’s how I solved it:https://answers.unrealengine.com/questions/821909/how-to-import-a-skeletal-mesh-to-unreal-engine-wit.html