Reverb G2 controllers not working in UE4 4.25.4

As the title say’s, I’m unable to get the Reveb G2 controllers to work with my project. The Mixed reality controls show in the Input section and I have tried to set them up to do the same as my Oculus Rift S controllers but they are just not being recognized. I have Steam VR installed and working fine. The Reverb G2 HMD is working fine though.

I see that UE4 4.26 will have an HP Motion Controller Plugin but what about Ue4 4.25.4?

Any idea’s on how to get the controllers to work?

Try enabling the “WIndows Mixed Reality” Plugin (restart required). This worked for my Reverb 1 controllers. Also Unreal now natively supports WMR, so there is no need for Steam VR to run, so you should be able to disable that plugin if you do not require it for your project. Hope that helps !

Thanks, already tried mixed reality plugin…but it’s not what I want to use to program with…performance is very horrible. My Oddysse + controllers worked fine with steam but not the G2 controllers. Steam VR is second preferred, Oculus is my platform of choice…just would like to use my G2 during development but will stay with Oculus for now.

Guess I’ll wait for 4.26 to be stable for using my G2.

Reverb plugin an or wmr plugin not working reverb 1 here. Have to make custom steam bindings with each new project here no way to import bindings it seems

I noticed 4.26.1 does not show G2 controllers and G2 controllers do not work. Plugins: SteamVr, WMR and HP Motion controllers enabled.

Hi, did you read this information and changed config files, mainly BaseEngine.ini (if you are using Steam VR)?…s?tabs=steamvr

I need to prepare some project for HP Reverb G2, but I don´t have this headset at home, so it will be like shooting blind :slight_smile: Would be great if you can confirm, if it´s working or not.

EDIT: So in 4.26.1 G2 controllers are working fine with Steam VR by setting both config files mentioned in that documentation and enabling HP Motion Controller Plugin. I guess in 4.25 it´s not working, because 4.26 is required for G2 (it´s mentioned there).

I’ve set both config files mentioned in thedocumentation and enabled the HP Motion Controller Plugin, as well as created the MotionController_Left and MotionController_Right under the VRCameraOrigin for VR_Pawn and VR_Character, however I am not getting any visuals of the Reverb G2 controllers when running my project in SteamVR or WindowsMixedReality. Any ideas? Thanks for your time.
Edit: I have tried launching in WindowsMixedReality, SteamVR and OpenXR

I confirm the same. Doesn’t work. Controllers not showing, buttons/joystick doesn’t work. You can only look around with goggles and that’s it.

I followed the guide and the controllers not showing/doing anything.

Yes, to all having difficulties, this is why I have stuck with developing on Oculus. Everything just works without effort. Spending time trying to get devices working instead of creating just sucks all the creative energy out of you. I’ve come to the conclusion that finishing development first, then enabling support for these devices afterwards is the only present and sane solution…until Epic does more than poke a stick at VR. Hopefully, UE5 will provide better opportunity for VR development…but at the rate of VR support declining…we all will have died holding our breath…unfortunately!!!

Where is Unreal Engine official support response? Where is a quick fix and update of the engine? Looks like they don’t care at all.

It’s not in Epic’s best interest to respond directly to every, or any, complaint from the community. That said, you can certainly trust that there are people at Epic that read the forums, so you are being heard. All we can do is have faith and trust that 4.27 or a 4.26.x release will fix whats broken.

4.26 is essentially a point release where Epic integrated a bunch of their in-house Fortnite tools to the public build of the engine, and my guess is it’s caused engine-wide issues that will take time and careful testing to properly fix. My recommendation, as Ive said in the forums before, is to keep your VR development to 4.25. My current base template for VR work is made with 4.25 and works perfectly with Oculus and WMR headsets, including Reverb G2. In fact, Reverb G2 is my main development HMD (and will remain so for the forseeable future). Ill need to double check my project settings for the exact config, but I can assure you that 4.25 works fine with Reverb G2 and the new G2 controllers.

Hi Bevman,

“It’s not in Epic’s best interest to respond directly to every, or any, complaint from the community.”

I strongly disagree with this. It is their best interest to respond to such issue or notify a fix is in the works.
Not working major and the best VR headset in the engine is a major flaw and should be fixed immediately. Day0 fix.

This is not some button working in a tool after you click it two times.

Community makes Epic Games a success company. Nobody else. People use Unreal Engine and make games/experiences, which makes money for Epic Games.

There should be very well trained staff especially for the forums, to find major/minor issues and report them to the dev team.
They should respond here officially to such issue like reported in this thread.

This is how it should work in a civilized way.
For months nothing changed. This is a misunderstanding then.

I get that its frustrating, but lets be real, not every fix can be a ‘day 0’ fix. Some issues take serious time to resolve and for a software suite as robust and complex as UE4, some fixes might have knock-on effects that break other functionality - in this case, the renderer. 4.26 has issues with rendering many things in VR, like translucent materials, and objects only appearing in one eye (and other VR features) which can have engine-wide effects. Will it really help anyone if a community manager dropped in and said “We’re working on it”? Epic’s silence means theyre working on it. Have faith!

And in the meantime, stick to 4.25.

@Bevman00 if you could be so kind as to provide a screenshot of what your G2 setup is in Unreal…getting it to work with 4.25. Or what you did with your settings, inputs, etc…to get it ti work. That would be so helpful for us who have not been able to get their G2 working with 4.25.


if you could be so kind as to provide a screenshot of what your G2 setup is in Unreal…getting it to work with 4.25. Or what you did with your settings, inputs, etc…to get it ti work. That would be so helpful for us who have not been able to get their G2 working with 4.25.

Sure thing! There’s not much to it, and full disclosure, Im using the Reverb via SteamVR. In UE4 the only VR related plugins I have enabled are Oculus and SteamVR, not OpenXR or Mixed Reality (and the HP plugin isnt compatible with 4.25, so im not using that one either). Then in inputs im using the ‘MixedReality’ options. For the Reverb controllers, ‘Trackpad A/B/X/Y’ are the face A/B/X/Y buttons.

Works exactly the same way as my Rift S once the inputs are set up, Ive just added a tweak to adjust the controller location and rotation so its consistent across both HMDs.

When you say “MixedReality” I’m assuming that you are referring to the “Windows Mixed Reality” category in the “Input” bindings. In there there is no “Trackpad A” or “Trackpad B” and the “Trackpad X” and “Trackpad Y” are referring to axis and not a button.

However what I do see under “Windows Mixed Reality” is, “Tackpad Up” , “Trackpad Down”, “Trackpad Left”, “Trackpad Right”. But I don’t know which of these translate into a/b or x/y on the g2 reverb controllers.

I’m trying to add support to G2 controllers without having access to them (so I can’t test it, I’m just going by user feedback I’m getting from Steam Discussions). If you could clarify further I would really appreciate it, really need to add G2 support to my existing project.

Thanks for the reply.

Are you able to get the G2 thumbsticks working? That is the problem I’m having, not being able to use the thumbsticks for movement.


I am using the Reverb G2 with 4.25 and I am using the Oculus Touch mappings for the controllers/buttons rather than the WMR ones.

@JohnoM546 would you be able to explain how to change from WMR mapping to Oculus Touch mappings. Should this be done inside Steam or in Unreal?
Ignore above, found it in project settings. It didn’t work for me however so the only way to move about is via the keyobard which induces motion sickness.