Resuming Character Movement

Hello guys,

I’m currently stuck with a simple thing that I know I’ll feel dumb once someone gives me a hint or answer to but
I am stopping the character’s active movement to simulate a “stunned” state. this allows me to knock the character back a bit, he’s suppose to stay still then resume his movement.

Right now I noticed blueprint has a Stop Active Movement node but not a Resume Active Movement node, or that I can find. I was wondering if you guys can help me out.

this is how ive always done it.

create a boolean called “disable movement”
in your movement access or really any input you want disabled during the “stun state” just put a branch there that says if disable movement is true, do nothing, otherwise proceed. You can get in the habit of adding it to any new inputs you’d want disabled.

Whenever you want to “stun” the character, just set disable input to true. Nothing will work. Then delay for 4 seconds and set it to untrue.

I have a function called “DisableOffDelay”. After setting disable to true, I immediately run a timer with a time of however long the stun is and then the timer automatically takes the disable movement off with the function. Saves the thread from having to delay processing(using delay node). Instead it completes and the timer then runs the delay off.

You can couple this with a small Launch Character to set them back and stun them. Also good for allowing animations to play. etc…

good luck.

I’ve just found out about three nodes which should solve your problem - Set Ignore Move Input, Set Ignore Look Input and Reset Ignore Input Flags (I work in 4.8.3). You will find screenshot in the topic below:

Hey guys, I ran into the same challenge as you did, and I have got an alternative.

Instead of using the “Disable Movement” function I found out that using the “Deactivate” and “Activate” pair of functions on the Character Movement component produced the desired effect.



When you Disable Movement component, it is really just setting movement mode to none. If you set movement mode and pick walking or whatever it was, it is the antithesis of the original disable command.
Hope that helps.

This is far more effective. Thanks

Agreed, this helped tremendously.