Download

Restart Level - Skylight gone

In 4.22, when I restart my level with a simple On button press > Open Level, it restarts but the skylight is missing. Everything is dark. It’s not like this on the original beginplay though and was never like this in 4.21 on restart. Any help would be appreciated. Thanks in advance.

@SplicedImmersive I’ve had a lot of problems with skylight rendering not being consistent. Have you tried switching to static / movable? Also, quitting the editor and restarting can sometimes help…

I’ve done both, no go. It works for when previewing but doesn’t work after it’s packaged.

@SplicedImmersive Ah, bummer. It’s a slow cycle to go through, repackaging every time. I’m afraid I don’t have another idea, although it does sound a bit engine version specific…

Have you tried a recapture? I saw this:

https://answers.unrealengine.com/questions/779294/skylight-is-broken.html

Yep, tried a Recapture in engine, which did nothing, and also a recapture at beginplay, which did nothing as well. Seems very odd. Thanks for being the only one to reply so far, haha. :slight_smile:

I believe I’ve fixed this now by pointing the skylight’s source type to a SLS Specified Cubemap instead of keeping it on the default SLS Captured Scene. Also turning off the ‘Lower Hemisphere is Solid Color’ option helped me get the look even closer to what I wanted after fixing this issue. I also disabled ‘Allow Static Lighting’ in project settings. Also making sure Skylight was on Stationary. Now when I restart the level, the skylight is there and working properly.