Download

[RESOLVED] Oculus touch controller buttons are not correctly mapped

Hi,

I am trying to develop a simple project for oculus quest, but the buttons seem not to be working correctly. Sofar I have noticed the following issues:

  • Buttons A and X are not mapped to any of the FaceButtons (1 through 8)
  • Buttons B and Y are mapped to FaceButton1 instead of FaceButton2. ‘Pressed’ is triggered at release
  • Grip buttons are not mapped to Grip1 nor Grip 2. Axis values are always 0.
  • ThumbstickY has always value 0
  • ThumbstickX has always value 0 except for the both ends (value is 0.5 at the left end and 099375 at the right end

I have tried both engine 21 and 22 with SDK API level 19.

Any ideas?

This is the official mapping of the Oculus Quest controllers: https://developer.oculus.com/documentation/unreal/latest/concepts/unreal-controller-input-mapping-touch/

Which version of the engine are you using? Which Oculus VR plugin version is reported in the log file?

I had tried it with engine version 19,21, and 22 without any luck. Meanwhile I have also installed version 23, and with that one it works. There is a new setting under Advanced APK Packaging that lets me choose which mobile device I am using (Quest vs Go/Gear), this wasn’t there in the previous engine version. My guess is that ue was using the mapping for GO controller, but I can’t be sure.

The 22 version is a bit old, you can try the 23 version

How to map Action Event when Oculus Touch grip buttons are TOUCHED? I have no problem mapping touches for triggers, thumbsticks and everything else, but I can’t find how to map grip buttons touching.

Also, the Menu button (left controller) is exposed in UE4 input settings but it doesn’t do anything.

If you get the Oculus-VR branch of Unreal Engine from GitHub, there are extended example projects covering inputs, mixed reality, avatars and more for all Oculus systems.

https://developer.oculus.com/documentation/unreal/unreal-building-ue4-from-source/