Download

Resizing HDR Textures - Megascans Trees

Hey guys, I’m not sure who this issue is supposed to go to, but I’m guessing it’s more UE4 than quixel.

Downloaded the early access trees, obviously loved 'em, but I’m trying to decrease the size of the assets, and unfortunately the imposter textures are all HDR.
Exporting those deletes the alpha channel, which is used in both base color and normal textures, and if I reimport I get this, which I couldn’t find online and no workaround I could come up with worked:
image

Both issues are present in 4.26 and UE5.

I need help with both issues (or at least the first one), and would love any ideas, thanks!

It could be because some of the textures (including the one in the screenshot) are a part of the Starter Content of Megascans, that it’s “already in use” and so doesn’t allow that new version / iteration of the texture to get reimported. Deleting the alpha channel is something else, and I bet it has to do with the HDR, which if you don’t have the correct settings for the texture and/or in the project, it results in alpha channel being removed. If I remember correctly, HDR may require the color mode / depth to be set at R8G8B8A8, also referenced as RGBA8 or 8RGBA. If not that, check your project settings to see if it’s in 10bit RGB 2bit Alpha or another type. It’s best if you can simply modify the texture’s settings directly outside of UE rather than a project-wide change in the color mode. But changing the Color Mode of the project to something else can show you if it’s where that problem is coming from.

Just tried that, changed both the texture format (not sure if that does anything), and project-wide settings, and still no dice :frowning:

I can’t find any way to get the alpha information out of the editor, which must be frustrating whenever you don’t have the source files, surely

so you’re trying to export the HDR imposters from Unreal? what program do you intend to import them to?

I’m trying to import them to Photoshop to resize them to 2k (from 8k)

If you touch the impostor sheet chances are you’ll cause the octhedral view to bug out.

You can try to just re-capture the impostor with the plugin by Brucks to just produce the size you want in engine.

Realistically, those aren’t game assets.
Converting them to game assets will take a bit more work, and from the introduction video probably some pruning at the model level.

Also, as always, the megascans material is not a good idea for anything except cinematic.
It is as overloaded as a vendor locked phone with bloatware.
To make a game performance requirements you can’t really have all those nice options that come with extra texture sheets…

I got an idea for you to get the textures out manually
Single channel screenshot from within the editor. Compose it back in photoshop.

If your screen is 4k, and you manage to go full screen on the texture the final result will be you just have a 4k texture…