Resave commandlet after switching to source build?

Recently we converted a project from using launcher build to our custom build.

Now while trying to use commandlet for resaving packages I got use warning on every asset

0]LogContentCommandlet: Warning:
Skipping resave of
due to engine version mismatch
(Package:8386587, Editor:0)

What should I do in order to make it work? :slight_smile:


The IgnoreChangelist flag causes the CommandLet to skip the change list check. I think the change list check is only valid when you have monotonically increasing changelist numbers (like in perforce), it doesn’t make sense with git commit hashes (which have no ordering when considered independently).

In my git source checkout, CURRENT_CHANGELIST is set to 0, and I believe is only set to something else by UnrealBuildTool when built from a perforce checkout.

Try this:

UE4Editor-Cmd.exe FULL_PROJECT_PATH\YOUR_PROJECT.uproject -run=ResavePackages -IgnoreChangeList