Replicating Pawn Possess

I have an asset I created that I am now trying to add replication to. Prior to going into replicating the asset, everything is working perfectly. Now to the question…

I have a pawn, which is a lock pick, that I am having the player possess. When looking at the possess node, I can see the correct pawn reference and player controller going into the possess node and the code after the Possess node is being called. However, none of my inputs are being registered for when I possess the pawn and I set up the node “Event Possessed” with a print string following it to display the controller. But it is not displaying anything.

I am under the impression that my possess is not successful. Are there ways to verify that the possess code is actually occurring? This will help me troubleshoot immensely if I can verify that the Possess is actually successful. I have tried calling the possess from level blueprints, player controller, game mode, game state, player state, character blueprint… along with custom events with every time of replication choice… at a loss here… Thoughts?

And this is for UE4.27

You only call Possess on the Server, it sounds like you’re doing it in several places on Server and Client which will break it.

Oh interesting. Alright, I will have to go through the code and look

I have made a similar setup with a lockpick. What worked for me, was running a script like this on the server:
image
Inside the doorBP the toggle door event is not replicated, and it spawns the lockpick pawn, and possesses it:

1 Like