Download

Repeat material instead of Stretching it

Hello,

I have a problem, I can’t find a solution however I google it a lot ! I’m sure it’s very simple but it’s getting me crazy !

I have a street, let’s say 10m long. I make a plane, I put the material on it. Then I streched the plane to fill the whole space of my street.
The material strech with it instead of staying at the same size and repeat.

You will say I can add texture cord to make it better. In my case it doesn’t work, because I have other streets with the same material.
One is 50m long, the other 5m…

And I don’t want to end up with 10 different materials because of tiling.

So : is there a simple way to make the material repeat (it is seamless) and not streching in order that it will have always the same aspect
independently of the size of the mesh, on every meshs. It will always be some UE4 planes so I think the UVs are not a problem.

For the ones who used Sketchup, I’m looking for the same system.
I uploaded a little video here : https://drive.google.com/open?id=1y1RxsMj19caM1oZ90aUxvsF6XOrZZlJO

If you have a solution, I will be very very gratefull.

(For now, I end up with building my street by adding small planes to other planes…)

Thanks a lot and sorry for the bad english.

I guess, what you are looking for, is some sort of world aligned texture. Here is an example:

For Master-Materials, use “Texture Object Parameter”, instead of “Texture Object”. With that you still can swap the textures later in the instances.

Hello,

thanks for your time.
it should works, but is there a more simple way like et in my sketchup example ?

if you just want to use it for a plane, then there is an easier way indeed. However, works only for two axis, so the texture of a cube will still get one side not scaled properly, if you scale the cube on that axis (z-axis in my example). Have no idea, how this could work with all 3 axis.

The Texture Object Parameter is feed into the Texture sample, because for some reason, the texture sample did not show up in the instance, after linking that stuff to the UV input. With the Texture Object Parameter attached, i just bypass this, since that does show up in the instance, and the texture can be changed again. Not sure, if this is a bug or working as intended.

1 Like

SUTHRIEL,

Hell yeah ! This is exactly what I was looking for.
If in the futur you find a way to do this on three axis, it will be also great, but for now the problem is 100% solved.

Thanks a lot !

OMG thank you! So easy.