Download

RenderTargetCube relflect translucent surface green-ish!

I’m trying to fake reflections with RenderTargetCube. Works pretty well but when my windows reflect others windows via the RenderTarget, they appear green. They don’t appear green on the rendertarget texture tho…just in-game.

My target cube is static, it does not refresh every frame (too demanding). Have an idea?

fcf0acc006ba10389789ad0021f920e77b94e075.jpeg
e6137fc7bbce20eb890d9be371cb866c3c6193df.jpeg

I noticed that this problem doesn’t appear in the editor viewport but only at runtime. Weird!

As there is no update method for the SceneCapture Actor itself, i think the quickest solution is a dirty hack to actualy move the sceneCaptureActor. So in your levelblueprint, get a reference to your SceneCapture actor, get the location and add 0.1 to z or any other axis, just a small increment. This way, the Actor updates itself once at the beginning and it should solve your issues. I am aware that this is a bad hack, but if anyone else has some better idea:)

It’s weird…it’s not possible to start the level with a static scene capture that you’ve already captured?

I found a workaround. If I untick translucency in the sceneCapturecube, then the rendertargetcube texture won’t include any translucent objects and at runtime the green ‘bug’’ won’t appear (and objects made of glass neither, like my glass vases, or pool water and windows)… Not a huge deal since the reflection of a window in another window is kinda hard to see anyway.

55a57bbaa5ab0e97a17d9d016f3fcad1dea57a94.jpeg

Do you know how I could achieve this? I’m a noob with blueprint (and any programming language actually).