Rendering without UV's

I’m tinkering around with a car showroom type thing…

I’ve got a bunch of very detailed car models but many don’t have UV’s…

What i want to do is use some kinds of IBL to light the cars but it seems like i’m getting into a lot of trouble cause UE4 wants to use lightmaps and i don’t have any uv’s so it all falls apart…

Is there anyway way to light and catch reflections on an object without needing uv’s?

Make either cars dynamic or all lights. Or turn off lightmass for them. This way Unreal will not create lightmaps for cars.

For reflections, use world coordinate materials, it will have stretched textures, but i think reflections will work.

And last but:
proper way is to create low poly meshes of those cars with uvs and render normal maps. Then create proper skins/materials in photoshop or substance designer.
Depends on number of car models, if its just few then improving them is worth the trouble but with many it depends on how good result you want.
I would make one perfect model for comparison, then play with low quality model and clever materials and compare results.

PS. If you have (or plan to have) any real texture on those cars, it will get stretched without proper uvs there are no miracles. This worldd coord uvs can only work with flat surfaces or some reflection only materials. But you really want normal maps for models, and that requires hi and low poly model and uvs.

Thanks for your input :slight_smile:

I’ve done this kind of thing before with other tools dealing with CAD data directly from manufacturers and been able to get pretty nice results without UV’s for the metal surfaces…

For what we are doing its not practical really to create a typical game mesh since the models we have are very highly detailed and often from cad so they are tri’s for this to be viable we need to be able to avoid having to do a lot of UV work…

You dont need lightmap UV’s for those cars then. Just give them cylindrical or plane UV’s and then import into the editor, and set their mobility to Movable in the level.

Thanks that has helped alot…

Now i’m getting some odd artifacting in the reflections though…

That’s SSR(Screen Space Reflections) quality. You can increase that in post process volume settings.

By the way, not related to this issue you are seeing but, dont forget to have a movable Skylight in your level if you happen to work with fully dynamic lighting someday, otherwise you wont see any proper reflection on reflective, movable objects.

Even with my SSR at 100% i still get that artifact just to a lesser degree can you override the max setting somehow?

I dont know if it is already at 4 by default now, but just to make sure close the editor > Find ConsoleVariables.ini in C:\Program Files\Unreal Engine\4.5\Engine\Config and put r.ssr.quality=4 command in it > Save the file and then start the editor and see if it helps a bit. You wont get crystal clear reflections no matter what though, so you may want to use a cubemap of the level in your metallic materials if you want a better solution.

To be honest i’m happy with cube maps :slight_smile:

Last question i promise can you adjust the cubemap resolution?

You can bring in high res. HDR cubemaps into the engine but the engine downsizes them to 512 in runtime. Apparently there is a way to increase that via the source code but i dont know how, so you will need to get help from someone more knowledgeable in that area.

I suggest trying what you have first though and see if the default resolution suits you. If the cars are the most important element for you you can just put the HDRI into your skylight or post process volume’s ambient cubemap slot and dont even bother with material integration.

Yeah i’ve being using the ambient cubemap slot and its looking pretty good…

I’ll see how the skylight works…

Thank you so much for your help!

Also check out this thread. You may find some useful comparisons on reflections there: Rendering a prop - how do I set up IBL? - Rendering - Unreal Engine Forums