Download

Rendered output looks nothing like the viewport

AS the title says, I’m having trouble rendering out a sequence, in the viewport i have everything set up just as I want it to look even in the cameras that I use, I have game settings unchecked, auto exposure turned off and yet when i render it out, the output is way more saturated than the viewport as well as seemingly having no fog in the scen if anyone has a fix for this it would be greatly appreciated.

I’ve had this in the past. When I solved my issue, it was because I had not realized that the game camera had it’s own post process and lighting settings on by default that I needed to shut off so that it would use the world ones post process volumes.

Have you checked that out?

Is this the settings in the camera, if so to what do i need to match them to or can i just tell the camera to not use its own post process? Thanks

ill need to get back to you as it’s been a very long time since i had that issue. But im curious - what happens when you eject from the pawn? do the colours change?

hi @Gprince11

I just thought of another thing. If you are working with a persistent level and lighting scenarios, you need to tell unreal which one to load on start. In your examples, it looks more like the post processes are not loading at all.

You see the documentation on that here - Precomputed Lighting Scenarios | Unreal Engine Documentation

It’s labeled as “precomputed” but this is valid for dynamic lighting also.