Download

Render mesh target image not showing on android

I have setup a project with a blueprint widget on 4.26. My end goal is to display a mesh render target as an image. I have tried debugging on the PIE screen, and two Android devices.
The image for the mesh render target appears on all devices but the render mesh material is missing so it’s just black. When I start in the PIE screen I can see that some green “wavy” particles rise up. I’m guessing this is due to a rendering error.
Also I have tried loading an image with just an image. On one of the devices this is showing up in the same way as the render mesh target material, i.e. it is just black. Not sure if this is related or not.

You can see the green particles I’m talking about in the middle of this image. That is where the rendering mesh target image should appear. That image uses the same texture as the one to the right.


Here you can see my setup for the mesh render material.

Here you can see how I setup the mesh render target with a SceneCaptureComponent2D. The size of the mesh render target is 1024 by 1024.