Download

Render Issue with 4.25

Hi,

I copied a 4.24.3 project to 4.25 then 4.25.1 to test these new versions and RTX (I have a 2070 GPU on my system). I ran into an issue that I do not understand thus cannot solve.

On a specific shader I have an unwanted sparkling kind of effect and do not know how to soled this. It doesn’t happen in 4.24.3…

My shader is pretty basic, with map directly plugged in color, normal, roughness and AO plus a constant in specular (tried also in metallic)

[video]http://www.cyrilgregoire.info/dl/GT - Unreal Editor 2020-06-05 21-02-48.mp4[/video]

Any idea ?

Thanks

+1 can we get some feedback please?

I’ve done a bunch of reading lately about sparkling effects / artifacts, and two things it’s frequently attributed to are incorrect mipmaps and AA. The issue concerns how mipmaps do not generate an exact ‘half resolution image/pixel’ at varying distances, but only at super-specific distances. IOW, the transition between mipmap levels (or LODs) is rendering a mipmap accurately only at a certain distance such as at exactly 10m or exactly 50m away from the camera. Any in-between distances are approximated based on particular methods of pixel sampling which is for retaining as much of the pixels as possible (there’s single, bilinear, trilinear, and another one I forget the term). Here are links to two articles about it, which is primarily applicable to MSAA in Unity. Since UE has TAA and a number of other differences in how mipmaps are generated and AA is utilized, it could serve as merely a reference for the basic issue, but doesn’t contain a full solution…only suggestions.

Another potential cause is out of bounds pixels. There’s a flag for it under Show > Visualization > Out of Bounds Pixels (blue and yellow lines signify pixels are out of bounds along those edges / areas). The projected solution would be to expand the bounds of the mesh(es) in question in the mesh editor.

@presto423 : What’s weird it’s with the same exact parameters, I have no problem at all in 4.24.3. I do not thinks it’s related to mipmaps (I already tried that). i’ll read carefully those links though.

i’ll check out of bound pixels as well just in case.

I tried with a new RTX enabled project, same textures, same shader and applied that shader to the default floor contained in the scene, and used default lighting and had no flickering at all.
@DanH71, maybe it’s something to be explored, i mean the lighting settings. I feel it has something to do with this problem…

For now I’ll stick to 4.24.3 and only do tests in 4.25.1 since it seems a bit broken for a lot of things.

Thanks for tagging me! In my particular instance , I tried visualising out of bounds pixxels as @presto423 suggested but there is no indication of pixels being out of bounds.
Interesting discovery on the default lights although what do you mean by ‘default’ lights exactly?:wink:

thanks again

@DanH71 : By default lighting setup I mean that I used in the basic setup provided when using a blank scene (directional light and so on) without modifying a thing. It’s a start one could use to compare things (that’s what I 'll do)

Well, it has something to do with Temporal AA sampling. when I tick “temporal upsampling” in project settings / rendering / default settings, it flickers a bit less…

Those were simply two possible causes or things that could be generating the sparkly stuff. I’ve seen a bunch of different threads with a similar graphical artifact, and almost each one appeared to be solved by a different approach / setting(s). It probably is a bug in 4.25, though it has happened in previous versions too.

yes, I had it in 4.24 also beta and full release. I guess it’s one of those strange ones. Just have to keep trying ways out to combat it until it gets fixed (if ever).

Hey,

tried the temporal upsampling suggestion [thanks for that] but no impact in my instance. If i find anything ill let you know so please do the same;)

pesky sparkles;)
D

It looks like it’s only on the dark tiles of the floor, and not all of them…primarily the ones in the more direct lighting hit area. It doesn’t mean it’s direct lighting causal, though how to check that probably involves modifying direct lighting somehow. What are the directional and skylight settings?

@presto423, sorry for answering only now. busy week. I’ll post the settings during the week end

Does it appear in-game, or in simulation, too?

Real time UE4 viewport, in game and simulation.

Hello,

****** HERE’S FLICKERING FIX *********************

Official 4.25 and 4.26 having some glitches in calculations, namely TemporalAAHistory structure was not filled out correctly

Here’s the only solution that will surely fix for both 4.25 and 4.26 versions (building from the source and fixing engine glitch), since 4.25 will not have any more updates and 4.26 also has the same issue:

  1. get Unreal 4.25 source, following link is a step by step instructions on how to get the source (no need for the building until you change buggy scripts, just when you get 4.25 source unzipped from git, run Setup.bat, after that **run GenerateProjectFiles.bat **): Building Unreal Engine 4 (UE4) From Source Code / GitHub - YouTube

  2. **change this 2 scripts **as explained in the below link, and finally, **build the source **
    https://github.com/EpicGames/UnrealE…48f5a38dfb53ea

  3. compile your project from source (in the following link, instructions are around 8.50 min): Building Unreal Engine 4 (UE4) From Source Code / GitHub - YouTube


Enjoy again your UE4.25/26

Cheers,
Mike