Render and interaction locations not matching in browser widget

Buttons, inputs etc interaction position and render are not matching. Interaction seems to be in correct scale, but it appears it’s rendering always as if the window was in the monitor’s native resolution. Also, it works perfectly when viewport is in native resolution size.

Steps to reproduce:

  • Create widget with browser and add to viewport.
  • Load any URL.
  • Test it in editor’s viewport without maximizing it.

My monitor’s native resolution is 1920x1080. It also happens on standalone game if in window mode or any mode not using native resolution. As I only have this monitor, I don’t know if it has to do with native res or 1080p exactly.

Hello RVillani,

I was able to reproduce this issue on our end. I have written up a report and I have submitted it to the developers for further consideration. I have also provided a link to the public tracker. Please feel free to use the link provided for future updates. Thank you for your time and information.

Link: Unreal Engine Issues and Bug Tracker (UE-37710)

Make it a great day

I see on the Issues page this is marked to be fixed on 4.16. Thanks Rudy and thanks to Epic devs!

Is there any update on this?

@Rudy Triplett : is there any approximate date for 4.16 Release ?

Hello L34D3R,

I don’t have any information regarding a 4.16 release of the engine that I can provide at this time.

This issue is fixed. Unreal Engine Issues and Bug Tracker (UE-37710)

Im still having this issue on 4.26