Renaming MyCharacter causes Default Property warnings and errors

  1. I create a new C++ top down project(may happen on others I haven’t checked).

  2. Build project and start editor

  3. Rename or move “MyCharacter” blueprint.

  4. Save/Compile and close and reopen editor

  5. get the following error:

Default Property warnings and errors: Error: CDO Constructor: Failed to find Class’/Game/Blueprints/MyCharacter.MyCharacter_C

I also tried changing this line in the GameMode.cpp file to reflect the change but I still get the error.
static ConstructorHelpers::FClassFinder PlayerPawnBPClass(TEXT(“/Game/Blueprints/MyCharacter”));

I have searched for other references but I failed to find any.

Hey -

Thanks for reporting this bug. I was able to reproduce this message and have submitted it to our internal tracking system (UE-5184) for further investigation.


Did you find a work around for this or is this issue fixed? I am actually getting that error trying to run my packaged game. I renamed my character blueprint and while I am able to run the game in PIE, i am unable to package it out and run it.

Hey kishoreven-

Are you receiving the same “Default Property” error when opening the project/packaged game? If so you can try changing the name of the character blueprint back to the original name and then repackage the project. If the message you are getting when trying to open the packaged game is different then it would be best to start a new post with details about your specific problem. This helps with both tracking as well as searching for separate issues in the future.


This happened to me as well today. Renamed a Character Blueprint, now I’m always getting this error. Is there any fix yet?

Hey zaha-

Are you getting the error in the editor as reported or when trying to play a packaged game as kishoreven reported? Have you tried renaming the blueprint back to the original name then generate project files by right clicking on the .uproject icon in the project folder or repackage the project?

Hi !
Thanks for getting back.

I eventually fixed the error message.The problem was, I copied a reference from the Unreal Ed to my PlayerCharacter Blueprint and used it in code to set my DefaultPawnClass in the GameMode. I get Blueprint'/Game/Blueprints/PlayerShip.PlayerShip' when copying it in the editor context menu, but this produced the error. As I later found out, the correct way to address it is static ConstructorHelpers::FClassFinder PlayerPawnBPClass(TEXT("Pawn'/Game/Blueprints/PlayerShip.PlayerShip_C'"));

Not sure if this is really a bug or if I misunderstood something here. Why does “Copy Reference” give me a string that does not work in this case? (still new to UE 4 :slight_smile: )

[EDIT] Oh and to answer your question: I got the error as reported when starting the editor.


Using copy reference will copy the file path to the asset (in this case the blueprint) to your clipboard. As you pointed out, using the pawn rather than the pawn’s blueprint is necessary.

More than 1 year later, it still happens.

Hey -

Can you provide the steps that caused this to occur for you? The steps in the original reported issue (Unreal Engine Issues and Bug Tracker (UE-5184)) do not cause the warning to appear for me in 4.16.2.

Got repro in 4.16, too.