Removing Lumen generated ghosting on flat surfaces

This is actually not a question but a guide to users suffering the same problem as I had.

I had some terrible ghosting in my UE5 project, and it very quickly became obvious that its not caused by temporal AA (turned it off, got rid of it from post process settings too, ghosting still appeared)

In the Valley of Ancient demo the environment roughness is fairly high, and rocky so this visual artifact is not visible.
However, if you set up a scene with lumen and the floor surface has a much higher reflectivity (around 0.2 - 0.5) you will see incredibly distracting ghosting if your pawn moves faster than the default walk speed. Maybe even at the default walk speed, haven’t tried it.
I’ve digged deep into the project settings of the Valley scene, and found that what is responsible for the ghosting is Lumen, and they way you can tweak it to your liking is by adding the a line to your DefaultEngine file in the config folder.
This is the one:
r.Lumen.Reflections.MaxRoughnessToTrace=something

in my case it was best around 0.3, it depends on how your floor (or other surface) reflectiveness is set up. Now this on the other hand generates some unwanted noise since lumen is now not really considering those surfaces to trace.
A workaround to find a happy balance is you can increase the Lumen final gathering quality (to 2 or maybe 4) which gets rid of most of the noise. This process is not really affecting the performance since you counterbalance the lower tracing with higher quality final gathering - my project stayed at the same framerate as it was before.

I hope this helps someone!

Thanks for this, yeah. I had a lot of ghosting problems with flat reflective surfaces and Lumen.