Remove "Target[Self]" section from boolean node?

Please note that I am very new to UE4 and I don’t know many things, so please explain everything to the fullest.

I am working through a Udemy course, and we’re making a blueprint that displays a text string whenever it is destroyed. When I insert the “bIsCarryObjective” node into the blueprint, a node shows up with a blue “Target[Self]” part on the left, and an “IsCarryingObjective” part on the right. In the video on Udemy, it only shows the node with the “IsCarryingObjective” part on it. How do I remove the blue part to avoid any errors, or what do I add to void any errors when compiling the blueprint?

This is automatic and depends on the owner of the variable. If you declare a bool in this blueprint and get it, you will not have a target pin on it. If the bool comes from another blueprint (object) it has to target that object as its owner - in which case you’d need to obtain a reference to the object the bool belongs to.

Hey, just had a similar issue and I had no references. Tried to do a LineTrace from my own BlueprintLibrary and there was always a Target Input-Node. Drove me crazy…

UNTIL I found a solution: if you truly aren’t referencing anything from the class, library etc., make the function STATIC. (like “static bool NAME”). This fixed it for me!

Yes, from blueprint library it must be static. If you make the function locally, lets say on a actor blueprint, then you need to make the function non-const (if it’s a pure function).