Download

Remote swarm agent stops doing jobs during lighting build (4.16)

I have 2 computers. They are both intel i7 PCs. One is an older one with 8 cores and showing up 64Gb of RAM. The other one has 12 working cores and 32 GB RAM. I can ping them both ways but they don’t work together very well. I’m running windows 10 home on both machines.

First I tried to make the 12 core remote computer be the coordinator but often the 12 core one would report rogue jobs that were than killed and I didn’t really see if the remote agent would finish any job at all or just do useless tasks that are killed every time for some reason.

Then I switched the coordinator to the other 8 core PC and it worked fine 3 times. Although there are large gaps were the 12 core PC doesn’t do anything for 10 minutes or more. Right now the 12 core PC did a lot of work 2% into the completion of the build but since then it is “currently available, unassigned”. Is that a normal behaviour? The 2nd PC has been idle for 4 hours now and the lighting build of the same project should have been finished a long time ago. There is no real new content added. I just had to move a couple of lights a little bit.

Any idea what would cause this? - There are no obvious error messages in the log of either swarm agent and there is nothing super complicated in the scene. I’m running 4.16 btw.

I found this old thread so I follow up on it. I finally got it working by giving rights to everyone in the cache folders and running swarm agent and coordinator as administrator.

But now I moved house and my internet provider sent me a new modem. Nothing else changed really so I suspect the new modem or one of the recent 100 windows updates messed things up again. My problem right now is that the remote swarm agent kicks in but after the “black phase” is finished the job gets killed and the one remote agent I have starts over and over again. - The lighting build is slower when using the 2nd machine.

I attached a screenshot. The log file shows some messages about "Rogue job"s being terminated. Anyone has an idea what causes this problem and how to fix it?