Remote swarm agent doesn't seem to get jobs

I’m struggling to get remote agents to get work from the coordinator. I have two machines: MillPC (Coordinator and Agent) and MillHTPC (Agent) on my LAN. MillHTPC stays “Available, Unassigned” when I start a build (large enough to typically take several hours). Both have the same settings in Swarm Agent:

Also, Swarm Coordinator can see both Agents:

The only clue I have is the following message when I ‘Ping Remote Agents’ from Swarm Agent running on either machine:


11:02:06 AM:     MILLHTPC (User = HTPC, IP = 192.168.1.137, Version = 1.7.2893.0) is currently Available, Unassigned
11:02:06 AM:     MILLPC (User = MILLHOUSE, IP = 127.0.0.1, Version = 1.7.2893.0) is currently Available, Unassigned
11:02:06 AM:     MILLPC: IP address for this Agent cannot be verified - Coordinator and local mismatch or DNS 

I don’t completely understand the error message. I still get the same error message when I enter the IP Address for MillPC (127.0.0.1) rather than the PC name in Swarm Agent settings.

Any ideas on what else I could try?

Thanks!

I’ve run in tyo a few problems with it in the past too. what I’ve ended up doing is just using mostly the default settings:

I’ve tried it with the name of the coordinator PC, it doesn’t work. I’ve tried it with named agent groups, it doesnt work. im sure there’s something that will make it work, but you have to understand that the swarm agent hasnt really changed since the UDK lol.

default, *, specific IP address. then it will work (hopefully).

as for the DNS mismatch, that’s just a non-error saying that the current system you’re on is the current system you’re on and not a system over the network.
:slight_smile:

Thanks Construc_. I’ve tried those settings, including listing the IP address manually, and didn’t have any luck.

However, I finally figured it out! The computers not only have to be reachable on the network, but the folder containing the Swarm Agent (or perhaps the CacheFolder itself) must be a shared location accessible by the machine running coordinator. Once I shared the folders (on both the coordinator and agent) things started working immediately. Hopefully this helps someone else in the future.

Hi,
Each of my computers have its own swarmcache folder that is not shared… the setting to specify the swarmcache location was good before?

OH you have to disable windows firewall, i remember that now.
glad you got it working :slight_smile:

Is it okay for IP address to stay at 127.0.0.1 ?

I’m having the same problem but the agent can’t ping the coordinator, i don’t know why my IP address on swarm is 127.0.0.1 instead of (for example) 192.168.0.13

The IP address will need to be changed to the correct IP of the computer on your network. The default settings there won’t likely work. Can the computer running coordinator ping the computer running the agent (outside of swarm)?

I’d start there first and make sure your network is set up correctly before messing with swarm settings. After that, make sure the folders containing the Swarm Agent executables are shared and visible to the coordinator machine.

The thing that worked for me was going to my computers Network Connections, and editing the Internet Adapter settings to Obtain DNS Server address automatically (I previously had a Google DNS setting to bypass the Australian internet censorship)

please someone help me
when I open SwarmAgent
or
when I want build lighting
I have this error
please someone help me