Remote Build Error - RemoteToolChainPrivate.key not accessible: No such file or directory

Hello, I’d like to report a bug I have discovered. Trying to remote build the ARSample Project on an iPhone from Unreal Engine 4.18 running on Windows 10 Pro 64bit (Intel Core i7-5500U @ 2.40Ghz, 12.0GB RAM, Nvidia GeForce 940M, 256GB SSD + 1TB HDD) to a Mac Mini running OS X Sierra (Mid 2011 Model, Intel Core i5 @2.30Ghz, 8GB 1333Mhz DDR3 RAM, Intel HD Graphics 3000 512MB, 500GB HDD) I was getting the following error:


Permissions 0660 for '/cygdrive/C/Users/<username>/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/<ip>/<username>/RemoteToolChainPrivate.key' are too open.

It is recommended that your private key files are NOT accessible by others. This private key will be ignored.

Which I solved by changing the permissions of RemoteToolChainPrivate.key by opening the cygwin terminal and typing these commands:

chgrp.exe Users /cygdrive/C/Users/<username>/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/adminsMacMini/admin/RemoteToolChainPrivate.key
chmod.exe 600 /cygdrive/C/Users/<username>/AppData/Roaming/Unreal\ Engine/UnrealBuildTool/SSHKeys/adminsMacMini/admin/RemoteToolChainPrivate.key

However, after solving this error I got a new one, which is the error this post is about:

 LogPlayLevel: UnrealBuildTool: Warning: Identity file /cygdrive/C/Users/myUser/AppData/Roaming/Unreal Engine/UnrealBuildTool/SSHKeys/192.168.1.xx/myUser/RemoteToolChainPrivate.key not accessible: No such file or directory

After many hours of debugging and going through the source code for the RemoteBuildTool, I realized that the tool is set-up to look for the first ssh.exe it finds and then tries to load the cygwin path. I had previously installed git tools on my Windows machine which also installed another version of ssh. If that ssh.exe it finds is a windows native version like in my case, it will run it with the cygwin path which is not a valid windows path and it will fail. I confirmed that by opening a terminal and typing:

where ssh

In my case showing the path ‘C:\Program Files\Git\usr\bin\ssh.exe’ which is a windows native version. I renamed that file to ‘ssh-1.exe’, and the error disappeared so the build worked normally. I do not think this is an ideal solution but it has worked. Please look into it and fix it in the future releases, as from what I have seen by browsing the forums many users have had this error before, and most of them did not manage to solve it. Please let me know if you require any further information


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.