Download

Remap NPC not working in v190?

I had all dinos remapped using NPC remap in a subclassed primalgamedata. Worked great in 189.22, updated to 190, recooked mod with 190 binaries, modded dinos no longer exist, do not spawn, and can not be spawned with cheat summon like previously. Even tried pulling a new dino_character_bp and setting it up with the new bps and it didn’t work either.

The other modders I work with had all been using spawn entries to mod their dinos into the game, did remap NPC break?

Did you remake your PrimalGameData_Custom? Haven’t tested this myself yet (I don’t use any remapped dino’s), so I’m not entirely sure what could be causing this.

One more thing, do you have the NPC spawners setup to spawn these dino’s in?

-Sinari

Same problem over here… worked before 190,
now both “Remap NPC” & “Remap NPCSPawn Entries” has stopped working…

Making a mod without making a new map, so I’m pretty much dodo in the water until this is fixed.

(Looking for a solution or a workaround meanwhile, will update if I find anything useful)

I’d recommend reading the patch notes on this newest update, they changed quite a few important things.

I didn’t use spawners because by the time I started modding they had introduce NPC remap. I subclassed primalgamedata so I would expect it to update on its own, but I am a modding newb so I could be misunderstanding subclassing.

I will take another look, I briefly skimmed it.

Well, to be completely honest I’m not entirely familiar with remapping NPC’s so I’m not of much help on this one currently :/. I’d take a look right now and try to help dissect this, but I’m having some problems of my own atm with my mod as well

Mod is working in the ue4 PIE, but not local or dedi, does that make any sense?

From my troubleshooting with my own mod, I just discovered the workshop is NOT intelligently updating current existing files from the looks of things with mods. I had updated Canna-Ark and it was showing old past version features/bugs.

This was after 3 hours of troubleshooting why my mod updates we’re not showing up in Local Play, but did in PIE.

Here’s my findings with Canna-Ark (this is an example that pertains to my mod specifically), maybe this will help you;

“Steamworkshop is being buggy with updating certain files. If you have problems with certain engrams not showing up from Canna-Ark, or missing features you are going to have to manually DELETE your mod folder (FROM ARK!!! NOT THE DEV KIT!!!) with this ID “481755557”, and then unsubscribe and re-subscribe to get the new changes. I don’t know why it’s doing this or being so finicky, but that was the fix for me.”

Only after deleting the mod folder & the mod file. And then Unsubbing and resubbing, did it work.

Not sure if this is the problem in your case, but I highly suggest trying this as its an easy attempted resolution with nothing to lose.

Did something similar to this already today, but will try these exact steps.

I did these steps and tried deleting the temp data for the mod as well in another location. If that doesn’t work let me know and I’ll track down the other steps I did for you.

Looks like this may be the issue, tho those steps didn’t help. I just noticed the version number that I increment is still back on the pre-190 version. It isn’t downloading the 190 mod.

Yup. Then its the same issue at play here. I’m going to make a new stickied thread about this I think at this point once we get it resolved for you as well, because at the rate we are going it’s gonna impact a lot of modders. Most of em would probably spend 3+ hours troubleshooting like I did only to realize that it wasn’t the mod at play. Some of em might even break their mods through desperate troubleshooting :confused:

Update: Here’s where I deleted the mod data in the additional location.

Workshopmodupdateproblem2.png

i’m 10 hours in here :frowning:

Nope, still did not work, still on old version.

Hmmm. I did those both and that fixed it for me. Not sure what else to suggest at this point :confused:

If I upload my existing mod as a completely new mod, it shows up as a map (right below ARK TheIsland) rather than a mod (in the little mod/active mod boxes) and doesn’t work at all. What on earth…

O.O’

Going to pass this info/issue onto the Devs. I have a feeling it’s still tied into the Steam Workshop being buggy with updating the mods.

I am redoing my mod from scratch to see what happens.

Back it up first, just in case :stuck_out_tongue:

And alright. It’s a bit of work, but you might find the problem along the way. Plus, hey, practice makes perfect right? xD

I’m beginning to think the UE4 editor is either not cooking properly or is not uploading the cooked files properly…