Download

[RELEASED] [SUPPORT] Female Hero: Action adventure

Hello. This asset support thread is Female Hero: Action adventure.

**Female Hero: Action adventure

Update 10.06.20 (01)**

  • Fixing up an body master material. Replacing the wrong texture sampler node.
  • Fixing up mistakes in the name of the morph targets.

Update Guide:

  1. Before updating, backup your project. Add the updated asset to the new project and make a migration to your project.
  2. Confirm assets rewriting. [HR][/HR]

A naked body available with quick guide.
Link to textures below:

https://drive.google.com/file/d/1h-WvioFGDv9t-r5BDmFQS57igIwjDFrG/view?usp=sharing

  1. Download and export *TGA textures to your asset wherever you want.
  2. Important! Disable sRGB checkbox in texture maps through Texture Properties Editor. The list of the maps:
    T_Body_Nudity_A_01_M
    T_Body_Nudity_A_02_M
    T_Body_Nudity_A_03_M
  3. Duplicate master material M_SkinBody_A_Master_01 and open it in the texture editor.
  4. Replace 5 texture samplers with similar ones without Nudity mark from the list:
    T_Body_Nudity_A_01_BC
    T_Body_Nudity_A_01_M
    T_Body_Nudity_A_01_N
    T_Body_Nudity_A_02_M
    T_Body_Nudity_A_03_M
    Save and compile material.
    • Advanced users can convert texture samplers to texture parameters in the original master material and replace this in the material instance.

An asset with breast physics is available at the link below:
https://drive.google.com/file/d/1L38…ew?usp=sharing

Hey Daemon,

Love the character!

I’d love to ask about an issue I’m having with the neck, there seems to be some sort of artifacting while in the level (lighting issue?). It does not appear in the blueprint viewport it seems.

EDIT: Same issue appears on fingers and toes.

On the left, in the editor viewport (realtime), on the right, in the blueprint viewport:
https://imgur.com/GVmJGCI

The screenshot I made with BP_FemActHero_Variations_A_03.

Sidenote, do you have a Discord available?

Cheers :slight_smile:

Hey.
There seems to be something with the lighting setup.

Right, any idea how we can fix it? I’m using UltraDynamicSky. The moment I drop it in, this happens. I checked further, the issue disappears when I disable “CubeMap_SkyLight” within UDS, somehow there’s an incompatibility with this.

So the problem is in UltraDynamicSky.
There can be many reasons. Maybe it is not compatible with sss shader
Try to disable the SSS nodes in the master material and check it out.

I had to do some more digging, but turns out it is not just UDS.

To reproduce it:

  • Create a new level in Unreal (default preset)
  • Set the skylight to movable

Notice how there’s issues around the head, fingers, and toes.

I tried the SSS thing but I don’t think it solved it. Could you try to reproduce it on your end with the steps I listed? :slight_smile:

Just checked on your request
I did not notice such artifacts.

What version of engine are you using? I checked in 4.19
In new versions, something new may have appeared.

](filedata/fetch?id=1772466&d=1591512806)

However, your artifacts are 100% related to the SSS (Subsurface Scattering) feature.
This is easily verified by pressing Atl + F3 Unlit mode view.

You can create new material without the SSS feature and check out these artifacts.

I tried again in an empty test project, and noticed that the auto-exposure masks the issue. For it to be visible, try locking the EV100 to a value without the auto-exposure by disabling the Game Settings exposure parameter:

(Here the issue is seen on the hands, for instance)

Good thinking, I’m on 4.24.3.

I’d be very sad to have to disable SSS, can’t we fix this issue somehow?

I checked the Unlit move view for you, looks like this:

The easiest way to solve the problem is to disable SSS.
I also wonder how to get around this problem.
Hope this can be resolved but I don’t know how.

upd:
It’s strange. I turned off the exposure and do not see artifacts.
Try checking on a different engine version. It seems your version is not stable.

](filedata/fetch?id=1772552&d=1591536659)

Also checked on 4.24
everything is fine.
I can advise you to turn off plugins and check it out in a clean project.
And reinstall or verify the engine version.

Hello @Daemon3d

Thanks for putting this great model up on the marketplace!

I already have a character blueprint with animations/blendspaces, different interactions, shooting etc etc. all setup and working. Now I was trying to finally replace the UE4 default mannequin with your female-hero figure. My UE4 mannequin has 1 skeleton mesh. The female hero-figure however is comprised of many different skeleton meshes (for modularity) with the head mesh as the root. As your figure is scaled and rigged to the epic skeleton (as is my UE4 mannequin) it should be a matter of simply replacing the UE4 skeleton mesh with your figure skeleton-meshes, right?
I tried assigning my UE4 Skeleton to the female-figure head skeleton mesh for example following these instructions: https://answers.unrealengine.com/que…mesh-help.html
It shows that the female hero skeleton hat many more bones than my UE4 skeleton and throws a warning “Failed to merge bones” and asks if I would like to regenerate the skeleton from this.
I don’t know how to proceed now because I fear this will mess up my existing skeleton… Could you please give me a hint how I could solve this?
My goal is to replace my single UE4 mannequin skeletal mesh with the female figure skeleton meshes and use my existing skeleton and animation blueprint.

Thanks in advance!

Best

Marian

Hello. You cannot just assign a skeleton. You need use retarget animation workflow.

Ok, thanks I’ll try that!
​​​​​​​

Hey, question! How did you set up her hair to have dynamics/physics? I’d like to have that working but I can’t seem to figure it out.

Hey.
Take a look at my other asset. This works the same way.

Thanks! It worked. I knew I was probably missing a step somewhere.

Actually, I seem to have a slight problem where the stray hair on the right side of her face jitters and goes wild constantly, even when I’m just simulating in the character BP. I was wondering if you might know what’s causing that?

This no work at advanced locomotion system v4, If i add skeleton program always crash, any idea ?

Hi
Play with the settings of these bodies and constraints or remove them.

](filedata/fetch?id=1776172&d=1592214962)

Hi.
This causes a crash on many characters assets.
I believe that you can configure to work. Better to ask the author ALS4.
I’m also interested in getting this to work fine. But so far there is no time to figure out.

Yeah, finally succeeded. Works :wink: