Regression BUG: Chaperonefloor offset when using WorldToMeters

A few issues (only two is consistently reproducable though). See the download repro project here: (see link below in comments)

1) When game is paused and the
chaperone floor is offset if i have
changed the World To Meters from the
defaul 100. This also don’t reset
even if i remove the pause, and play
the game again.

2) When game is paused the HMD
display artefacts on the screen.

3) When game is paused (possibly
related to 2), the Widget
Interaction Component sometimes fail
to hit it’s target (the buttons),
possibly because of gfx artefacts
blocking.

The repro project is based on the standard VR template and has few changes in MotionControllerPawn, Begin Play where i call a custom event Allow Tick While Paused on each of the controllers, and i wait 6 secs before pausing the game, then after another 6 secs i unpause the game. Notice the floor offset 1) and 2) gfx artefacts, and if you don’t unpause the game, then once in a while (sometimes once every 50 times, the Widget Interaction Component won’t be able to hit it’s target 3)).

Both MotionControllerPawn and BP_MotionController are set to Tick Even when paused, as are the “MotionController”, via the custom event: Allow Tick While Paused

Stop the game, and unhook the call from MotionControllerPawn.BeginPlay and observe that the floor is still offset. This will continue until i restart the editor.

Let me know if this can be reproduced on your side or not. Also setting Global Time Dillation really low as others have suggested is not a good solution it seems, as this will cause serious lags if i wait some time and then resume (my theory is that some stuff gets queued up and needs to catch up).

Btw. Just to add a bit more to this question:
4.15+ 4.16+4.17 does NOT mess up the floor level, but all of them leave gfx artefacts
4.18.1 still offset the floorlevel and gfx artefacts.

I realize i dumped 3 issues in one question, so please let me know if you want these created as seperate questions with each it’s own focus. I just thought that since i see them all together, i would keep it together.

Hello Jonas_Molgaard,

I tested the project provided and I did not run into any of the issue mentioned in your post. Also, as mentioned you have provided multiple issues for a single post. I would suggest creating new threads for each issue. For this thread we will concentrate on the chaperone floor being offset. I have a few questions that will help narrow down things further.

Quick questions:

  1. Could you try downloading the provided project and insure that the issue still occurs in the project after being zipped down?
  2. Could you provide more exact steps for reproducing this issue in the project provided?
  3. Could you elaborate further on what exactly you mean by the chaperone floor being offset?

Indeed i can. I will record a video of it and post, and keep the focus to the floor offset. Btw pls note that the offset of the floor can better be seen if you place a controller on the floor and ie. set the World To meters to something like 200 (but any value different from the default 100).

Here’s a video explanation:

And here’s the project to reproduce. Btw. for my particular project i need it to scale over time like i show on the video, and can’t just set it one time.

Project and Video uploaded… See below.

I’ve found that since updating to 4.18 world scale to meters does not work at all. Or rather it half works on initial start up. but as soon as I open a blueprint or try edit any settings it it seams to return to 100 no matter what it is set to.

Hi Rudy, i haven’t heard from you in a while on this matter. Is there a chance you can update me (and the others) on this issue? Did you try the last repro project? - YouTube
Dropbox - File Deleted

I ran a few more tests with the new project provided. I am not seeing an offset on our end. Are you referring to the scaling that is happening when the World to meters value is changed?

Hi Rudy, i can’t really narrow it more down, other than upload maybe a better video showing the issue. As i mention on the video, the floor (chaperone) starts to raise up, so it seems like im floating up in the air, and the tracking is completely off. So i take it, that you can’t reproduce the experience i show on my video? that after the 10 secs, when the world starts to rescale, it stays fine on the ground as expected with you? I should mention also im on HTC vive, not that i think it matters. Just to add to the info. Anything else you can think of that i can do on my end to get closer to the issue?

I would really like to hear if others see this problem, or it’s just me? Can someone please try download the repro project and let us know if it’s reproducable or if it’s a local problem maybe?

Just applied hotfix 4.18.2 and now it’s not offsetting anymore. I didn’t see it in the patchnotes, but assume something was done :wink: Thanks.

EDIT: I was a bit too fast there sadly… i started it again, and now it happends again.

EDIT2: So what happends here, is that when i start the editor and hit play, it works. If i then go in and change something, like add a cube component to the VRPawn and recompile, and hit play, it does the thing… Rudy, can you please try these steps and let me know if you still can’t reproduce it? If not i’ll send you another video showing what i see, since it may be hard to otherwise see.

I have the same issue, happens in a clean project but only on HTC Vive, it works fine on the Rift

On 4.19 and this stuff is still bugged…

On issue: WorldToMeters is ***** as hell when you have other unreal tabs open except the default editor window. Close all tabs (Blueprints, Static mesh editor, material editor, …) and hit play (that at least somewhat works).

Hello,

We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks