Reflections tiled in 4.7?

I just copied my project to 4.7, and I’ve noticed some differences in reflections. A few of my reflection captures had shifted their priority a bit and some reflections were showing up in places that they didn’t in 4.6. It’s hard to give details, but it was easy to fix.

The one thing that is [was] driving me crazy is that a box reflection capture was producing tiled reflections on my mesh. The three segments of this elevator wall are scaled beyond the 0-1 UV space, which might have something to do with it. Rebuilding lighting and toggling visibility of the probe wasn’t changing anything, but in the middle of writing up this post, the problem has resolved itself. So I can’t even test it for you anymore. But here’s what it looked like.

Edit: It’s back. It un-fixed itself.

Hi StephaBon,

I’ve tried to replicate this on my end but cannot reproduce the same issue. If you delete the offending box capture and replace it with a new one does the problem persist?

Also, is this happening only in this project opened from 4.6 to 4.7? My trial with converting an older project of mine with 4.6 to 4.7 didn’t show the same results.

Deleting the Box Capture switches the reflection to a different sphere capture with the same result. I brought this model into the Realistic Rendering scene that was converted to 4.7 and it has the same problem!

Then I created a new blank project and imported this same asset. Giving it a shiny metal material and a new reflection capture gives this same Triple-Reflection

I don’t know why this model would be so special, but I’ve uploaded it to DropBox if you want to test it out. I’ve been sticking to 4.6 recently, but I haven’t noticed this issue with other meshes in the same 4.7 project when I was looking around.

Hi StephaBon,

Thank you for the asset. This has helped me see the same results and I’ve submitted a ticket for this issue (UE-11205). At the moment there is no eta for when this will be addressed, but once there is any relevant update I will make sure to post here.

Thank you!


Hi StephaBon,

In 4.8 we’ve added the option to disable MikkTSpace in the Static Mesh Build Settings. Applying the settings without MikkTSpace enabled will return the reflection to the way things worked in 4.6.

If you’re using source builds you can pull the CL-2519373.