Download

Reflections problem

Hi guys im new here and new too with unreal engine.
I have a big problem (maybe) with reflections in my first scene.

I begin learning ue4 with a tutorial of digital tutors and then with this (https://forums.unrealengine.com/showthread.php?28163-ArchViz-Lighting) <— hail koola
Because i need to make demo for museums and architecture.

The problem is that i start a new empty level, setting up all with koola parameters and i cant make reflections to work.
If i turn mode view “lighting” i cant see the screen space reflections but if turn on “reflections” all the shaders show the reflections, so i think its only a setting problem.

On the table i put a cube from maya with a “glass material” with refraction and don’t work, just cant reflect anything.

ive researching on internet and cant found a solution.
halp me please is frustrating this **** :frowning:

2b153b02cdca3d5e203b908950806a7def20d2f9.jpeg

db804cf7c46607ab20b4726a56d723409cb0a520.jpeg

It looks like you have the glass material on everything, glass can only use the reflection probes for reflections.

Also, your lightmaps have a very low resolution which is why the shadows look bad.

glass material is only on the glass over the table, the white shader is just a lambert from maya :stuck_out_tongue:
thanks about the information for the lightmap, i will fix it now!

maybe reflections are too low? Can i increase the intensity of reflectivity in the scene?

bbc3370f6fc09423b31f0b2b9e9770eb47cf3e93.jpeg

Oh, sorry, I saw the reflection preview and thought that was the final render.
Make sure your scalability settings are set to Epic, it might be that it’s on a lower setting that disables SSR.
Getting the correct shadows will also help. You might also try using a directional light instead of the lighting setup from Koola, it’s not really necessary to do it the way he did, you can get a similar effect with the directional light and adjusting the environment color/intensity in the lightmass settings.

Try putting a value of 1 into the metallic slot of the glass material and see if you get reflections. It’s not physically correct, but it’ll show if you are getting any reflections.

thanxs man i have a directional light in the scene and epic settings :frowning:

thanks too ive trying with metallic just dont work haha
If i zoom in into the glass i notice a very very low reflect i think reflections its working but i need increase the intensity a lot.

Can you post a screenshot of your glass material setup please?

Thanks Jacky here is:

Specular 10
Rough 1
Opacity 0.3
Blend Mode: Translucent
Shading Model: Default Lit
Translucence Lighting Mode: TLM Surface

its all.
ive created a new level that come with reflections for deffault and nothing, i think its not a problem with the level, its a problem with global settings or hardware/driver :confused:

c1ba0fb22ab74491fde8301195f8829b79a22216.jpeg

Roughness needs to be 0 for reflective surface since 1 means rough. Bump up specularity to 30 and give metallic 0.1-0.3. Also either unplug refraction all together or set it’s parameter to 1.1 or smaller.

Perfect.
Tried your settings and changed blend mode “translucent” for “opaque” and voila! REFLECTION WORK!
Ok the problem is the translucent setting.
wow i very happy for now thanks to all of you guys!

e60bfef69bb46ccebb9efc6a490fe271ae3dcb7d.jpeg

The problem was probably the roughness being 1, not the translucent vs opaque, although there is some weird issues with translucent materials and reflections, but there should still be some.

But i tried a lot of times with roughness = 0 and nothing happened.
When change translucent for opaque and bump up specular to 30 all works i think are a mix of errors.

Know how to fix this? In maya Uvs, normals and tangents are ok (imported to ue4) :confused:
Finally my work its stay hours and hours learning to fixing ***** xD its better begins a more simple scene maybe.

f9b93380-1e30-401b-8ddb-feef35e8b4ce.jpg

ok its fixed :stuck_out_tongue:

You need to set the translucency type to TLM Surface to see reflections, but only from spherical/box captures, skylights or ambient cubemaps.
SSR on translucent surface will come on 4.8 i think.

thanxs max my shader its working now and the problem was the “refraction” nodes. The glass shader i was trying its the deffault real engine glass material that come for deffault in a new project.
Finally with help of a tutorial of refraction the shader works. Have a very very low and unrealistic reflection but well its a advance for now :stuck_out_tongue: