Download

Reflections in PIE not the same as in editor viewport?

Hi guys, little help if possible please - been trying to find a solution for this and although this subject had been touched on in other threads I still haven’t found a fix, so any suggestions are appreciated.

I have a glass window that looks pretty nice in the editor viewport (I want it to look ‘sweaty’, will tone it back but that’s essentially the effect I want), see below. Although this problem seems to effect all transparent objects in my scene, I’ll focus on the glass:
](filedata/fetch?id=1863775&d=1613639696)

Then when i click play in editor (PIE), it then changes to this…the reflections are barely visible (see below):
](filedata/fetch?id=1863777&d=1613640157)

Few things worth noting about my scene, that may help:

  • I’m using ray traced reflections, but ray traced GI is off.
  • I have a sphere reflection capture in my scene, it uses a cube map. But changing the ‘reflection source type’ to ‘scene’ doesn’t seem to change the final result in PIE.
  • I also have a planar reflection box set up on the glass, however when i delete this or make invisible it doesn’t appear to be doing anything (when viewing in editor viewport anyway). So maybe I’m using this wrong? I also tried using a planar reflection on a mirror which didn’t seem to have any effect.
  • I’ve also checked 'Support global clip plane for Planar Reflections’ in project settings/optimizations.
  • Just to re-iterate, this problem seems to effect reflections on all transparent objects in my scene, so I don’t think its something necessarily to do solely with the glass material/actor. Even rendering a cinematic out, the reflections ‘disappear’ from transparent objects or are barely visible compared to editor viewport.
  • Glass material shader is set up like so, other transparent materials set up a similar way. Surface/Translucent/Default Lit with Surface Forward Shading:

](filedata/fetch?id=1863778&d=1613641197)

Any help would be much appreciated. I can use screen space reflections if needs be however it doesn’t look half as nice.

Thanks!

Update - I manged to fix the issue, needed to build the reflection captures!