Reflection problem in UE4.18 and UE4.18

Recently I started learning Unreal Engine for archviz.
For learning purpose I made a test room to analyse lightning, shadows and materials.

Everything was going good but recently I downloaded the latest version 4.18 and then updated it to 4.18.1 .
Reflection in model in 4.17 was great but when I opened the project in 4.18 there was loss in reflection and ugly reflection on test spheres as you can see in screenshot.
Even making the room freshly in 4.18 didn’t help and same problems were encountered as I updated to 4.18.1 .
I would be highly thankful for a solution to this problem.

Buid 4.17

Build 4.18


Try deleting and replacing the reflection capture actor. Also see if the SSR in post process settings is messing with the reflections in a negative way by disabling it or increasing the quality.

Yeah, it looks like it’s only using SSR

Buddy it didn’t help.

Please check the post process setting screenshot I am attaching.

You have reflection capture actors though right? Those will be necessary for objects to have reflections of other surfaces that are out of frame. And you’d most likely need to rebuild lighting when switching from 4.17 to 4.18

I tried to rebuilt the model from scratch and rebuilt the lightning in 4.18 but same issue.
Yes I have reflection capture actors in place.

Any chance that you went from deferred to forward shading? I had a case where interaction (‘prioritization’) between the reflection captures all went haywire because of this: forward shading standard doesn’t handle multiple reflection captures in the same way.

I found the problem but its an engine bug.

My PC only supports shading model 4 (Under setting > preview rendering level > SM4), it’s quite an old one (don’t laugh at it!) Xeon E5440 (quad core 2.83GHz), ECS G31 board , 4Gb ram and Nvedia 8400gs, which only supports Shading Model 4. You might say this hardware is incompatible but it works perfect for learning purpose till UE4.17, right now I don’t have any plan to upgrade my pc because I am a student.

First I thought my windows have some issues because I tried to gave a shot on my friends PC, in that PC it worked fine on 4.18 but when I explored more I saw SM5 was selected, so I switched to SM4 and bingo same problem was encountered in his pc too.

That’s not an engine bug, it’s a limitation imposed by the Shader Model. Nothing Epic can really do about that.

But why in UE4.17 reflection were fine in Shader model 4 but not in 4.18?

4.18 deprecated SM4

So Epic should completely remove SM4 option from unreal.

Almost any card you can get now thats with in a couple years old will support SM5 even low end one. Your 8400gs is ancient man. Could get a card 10x better for probably under $100 or a little over depending were you look.