Download

Reflection issue

Hi,

I am working on an office interior scene.
I have issues with the reflection on the floor.
How can I make it smooth and get rid of this raster like noise ?
All the settings are on “Epic”.
I am using a Quadro 4000 gpu now.

Thank you,

Geza

2f96dd0108e792f0213ff57fe89af4e4e591f077.jpeg
34278ff1086717132c0a15fe70180ce16265ba30.jpeg
c04ad17badd8d932800fd755dcbcf50e1eacf675.jpeg

Create a Post Process volume and then in the settings increase the quality of the Screen Space Reflections

Thank you !
I will try it as soon as I get back to the editor from max :slight_smile:

So I updated the values at the Screen Space Reflections but noise is still the. (just got smaller)
The other issue is the camera movement with the reflections.
When I move the camera I see the reflections “updating” from rough to clear in a few seconds.
Is there any way to solve this? :S

ace127f63b026fb160b50dcaf5cdf71ee15077e3.jpeg

You can improve the quality even further by using the command line “r.SSR.Quality 4” when in-game

Thank you !

might be good idea to add roughness texture to mask imperfections in reflected scene also take look at Reflection Environment | Unreal Engine Documentation

I give it a go :slight_smile:
Thanks

So the roughness texture helps to hide some noise.
The other question for me is the glass shader.
The visibility is almost 0% from inside. (I understand the scenario with reflections and stong backlight)

This is the tutorial I used for the shader creation.

Is there a way to “fake” the glass or make the reflection much more stronger ?

ce1ebeca328f8a352b50d01a5da626a9ba82fb7c.jpeg
ed9de33990088d6247a0d832a4aaef9073bd5591.jpeg

Thanks

To take this further. you can also modify the ssr config file - check out the details HERE
You can bump up the quality quite a bit from the default settings if your video card can handle it.

Sounds like a plan for me :slight_smile:
Thank you guys

Boosting those reflections seems kinda tough, I’m starting to see that transparent objects are one of the main limitations for quality arch viz…

Here’s a ‘fake’ that seems to be working more or less -
create a scenecapturecube camera in your scene, then make a target texture (material and texture, cube render target). Bump up the resolution for that target and use it as a Base Color for the glass material. Set up ReflectionVector as the tex coordinates for the cubemap. You can multiply the cubemap with a constant for darker/brighter reflections and lower the opacity for the reflections to become stronger. I can bump up the reflections quite a bit this way.
Haven’t worked out all the kinks yet, but I guess it’s a start.

3aaf9926fedfffb98dde59f86bd05dd58f9e3063.jpeg
e53e13e87f8d65f2e0aae9ae39e6329edb54c1d7.jpeg

Thanks,
It helps a bit but I guess we would need more props inside to see proper reflections and not just the architecture what is quite simple in this case.
I hope we will be able to push the scene further since the first presentation will only contain an empty floor level.

Hi,
It seems like the reflections are missing from the floor when I capture a video…
Any idea how to fix it? (all settings are on epic)

d9687d2bd4cc7c481a37962b11ca90ee916640f2.jpeg

What are you using to capture the video? I’ve used Matinee and reflections show up fine.

I managed to find the problem.
When you create a new camera inside matinee the “Screen Space Reflections” are not activated in the details panel of the camera.

I mostly like SSR except that they reflect things they shouldnt and “breaks immersion”

Also with Temporal AA and fast moving anything they add a significant amount of noise

Yes the noise is too much sometimes.
And it is not suprising that you need a proper gpu :slight_smile: