Reflection captures need to be rebuilt message is only visible in standalone or in a packaged build

The message warning to rebuild the reflection captures is only on screen in standalone mode and on a packaged built but it doesn’t say anything in PIE. The reflections are being shown correctly inside the editor and in a standalone/package.

This is happening after I changed the version from 4.19 to 4.20. I tried to rebuild the reflections captures inside the editor but the message it is still there. Before changing the version I deleted all the intermediate folders to avoid having problems with something outdated.

I don’t know what else to try.

Thank you for your help

I’m having the same problem. I am also in 4.20 but I haven’t verified that making the switch to 4.20 was the issue.

It definitely appears like the reflection captures are working so I ended up just disabling the on screen messages for each level that the issue persists.

So just add a Execute Console Command node at your Event Begin Play and then use the console command “DISABLEALLSCREENMESSAGES”.

Sorry I don’t have a better answer.

2 Likes

I am not sure if the issue was making the switch to 4.20 but in 4.19 the same levels worked fine.

Yes, it seems that the reflection captures are working which is weird. I am worried that this might cause other problems but so far everything works fine.

Your trick works to hide the message so at least is a temporal fix. I will try to look into it and if I find the source of the problem I will let you know over here.

Same Problem here

A solution that worked for me is to package the game for shipping not for development. You will find the option under:
File_PackageProject_BuildConfiguration.
Hope this helps.

1 Like

Yeah, in shipping all the screen messages disappear by default but if something is not working properly it will stay there. I haven’t made any test yet but it may affect performance if is making extra checks. Right now it could serve as a workaround but we personally need development builds for internal testing.

This looks to be caused by the CubemapSize = 0; set in
FReflectionCaptureData::OnDataUploadedToGPUFinal in MapBuildDataRegistry.h
The query for the reflection data is failing due to the CubemapSize not being the expected size.
I have pulled it, and reflection reflection captures are back to working.

Hi, what do you mean by “pulled it”?

I removed it. It’s no longer set to zero on UploadToGPUFinal.

I am pretty new to UE4 and not quite sure how you have solved this problem. Would you mind to provide a step-by-step solution.Thx!

Hi, I haven’t had the chance to test this solution yet but knowing the issue it seems like a bug in the engine code, have you reported it as such so they can fix it or send a pull request? In my case making changes in the engine code is an issue as I am not distributing a custom build version to my team. Thank for the info.

Hi, I have experienced the same issue. The way I fixed it was moving all the SphereReflectionCapture from the sublevels to the PersistenLevel and then rebuilding the reflections once again.
Also, make sure the amount of SphereReflectionCapture are less than 341
If it doesn’t work, try deleting all the reflection captures and the creating them again.

1 Like

Was having the same issue in 4.21.

The way I fixed it was moving all the SphereReflectionCapture from the sublevels to the PersistenLevel and then rebuilding the reflections once again.

This fixed it for me.

1 Like

I fixed this problem by opening the details of each SphereReflectionCapture and reflection source type to captured scene, they were on specified cubemap but no cube maps were set in the options.