Download

Reflection Capture view distance too low

I have map with a cave in it. Inside the cave, I have placed a reflection capture actor.

The far clip plane used when the reflection capture cubemap is rendered is much too close, however:

The ceiling of the cave gets clipped, so the reflection cubemap shows the open sky, resulting in completely wrong lighting for actors within the cave.

How can I adjust the view frustum / far clip plane for the reflection capture actor?

The problem seems to be a bit different than what I thought. I put a sphere reflection capture actor and my reflecting sphere into a very small room and it still shows the sky.

So it’s not the view frustum of the reflection capture but the fact that somehow, for some reason, the sky sphere is superimposed on the reflection capture image.

If I delete the Sky Light from my scene, the reflection captures show the correct image, but my whole map goes dark (I’m using dynamic lighting only). How can I avoid this?

I still haven’t found any solution to my problem.

By chance I tested my project on a Windows system and it did not show the sky sphere there. So I will report this as a Linux-specific bug now.

I have now found a workaround of sorts.

If I set post processing settings to Epic (and not a single notch less), the Sky Light stops being superimposed onto the Reflection Capture cubemap.

That’s really weird. I wonder if that’s working as intended? Have you tried posting this to answerhub?