Reflection Capture Changes from 4.19/4.20 - 4.21/4.22 // Only Sky/Fog reflected

I noticed some issues with the reflections in my projects, namely, that the reflections in levels that have only movable lights are absolutely black until I switch my lights to static or stationary.
I assumed this was a bug, because I could get reflection capture actors to capture such scenes just fine in older engine versions. After posting a question on answerhub I did a few test to find out when these issues started.

I created a modified startup Level on UE4.11, set the directional and skylight to movable, set “Force no precomputed lighting” to true and build the light once to get rid of any Lightmass residues.
As expected, the reflection capture rendered the scenes correctly, including the sky and all static meshes. The reflections would also update in the editor when the capture actor would be moved.

I then worked my way up the version list to find out when the reflections broke. From what I can tell, this very same setup results in pitch black reflections since 4.21 and locks darken then the 4.11 in 4.19 and 4.20. Here are some Screenshots. All were taken from the same project after upgrading it to the next Engine Version. I then hit rebuild reflections and changed or touched nothing else.


4.20: Similar to 4.11, but darker. Note that the results in 4.21/4.22 are not just even darked, but a perfect black that can not be fixed by boosting the reflection brightness. I also noticed that it seems to reflect the Sky and Fog correctly and only renders meshes/materials black.


Can anyone else verify these issues? All I did to produce these testcases was create a new project with starter content, switch the skylight and directional light to moveable in the startup level, then I rebuild the lighting after setting force no precomputed lighting under world settings to true. In the latest versions it also appears to be nessesary to click “build reflections” since the capture actor does not recapture the scene automaticly when moved anymore.

I tested a few more things, and it turns out, that it is possible to work around this by setting “force no precomputed lighting” to true and temporarily switching the lights to stationary. It is then possible to bake reflections without having used any lightmass prebaking in the level and once the reflections are build you can just switch the light back to moveable while keeping the reflection captures.

This hardly seems an improvement over the 4.20 version which just worked with moveable lights by default, so in lack of any feedback so far I still think this is some kind of bug. I also testet this on 2 other PCs with identical results. Could anyone please respond and confirm or deney that they encountered this issue in 4.21 or 4.22 too?

Have the same issue in 4.22, still happens in 4.23. Thanks for providing the workaround fix, at least that worked for me as well!

Just click build lights only.

I have built lights only too but it doesn’t update!