Reducing Texture size in the editor

Hey guys,
I have the situation that some of my projects have very large file size due to 8k textures. I know we have the ability to clamp texture resolution when cooking. However I don’t know how to use those cooked textures in the uproject/editor.

Does anyone know a quick way to reduce texture size for the entire project? (preferably reducing the texture size to the size specified as ‘max ingame’) for instance using the cooked textures instead.

The only option I can see currently is to manually re-import my textures at a lower resolution.



Go to Window->Developer Tools -> Device Profiles
There you can change several Settings for a certain Device Profile (Desktop, Mobile, Console etc)

That’s not what I’m looking for unfortunately. I’m looking for a way to reduce the ‘resource size’ in the actual project, not just reduce it once cooked.

you have to manually do it if you want to resize the actual source.

Keep in mind that UE will automatically use the Device Profile Settings you are working on. So if you are working on Linux and set the Texture Size to 512. All your Textures will automatically use 512 even in the Editor

hey, sorry it took a while to get back. Thanks, yeah it’s just a painful manual process and my main concern is cutting down file-sizes for certain assets. It’s a shame there’s not a built in system like that!

qwertyuio.pngYou need change “Max Texture Size”

Writing over your original file is dangerous as it can cause you to loose the original.

When cutting down from 8k to 1k you would really be better off using Photoshp/GIMP/KRITA etc. and applying a custom algorhytm to the reduction process so as to better control compression artifacts.
The engine does a really decent job, but there is no comparison to what you can do by visually deciding the resample style…

I’m still really curious as to what you are cooking up with 8k textures and over the max limit of grass XD

This doesn’t change the filesize on disk. Which is what I’m looking for. Please re-read my original post.

Yes I want an automated way of doing that though. It’s absolutely possible and would be a very useful feature.

It would only be dangerous if you don’t know what you’re doing. :wink:

The same issue exists in Unity - the only solution is to setup batch mode using something like Gimp to mass-resize all of the images.

However as others say, be careful as you can easily create artifacts or errors, and you need to ensure you still have access to the originals somehow.

In an optimal world you would have a completely custom art pipeline where all textures are designed to match the final image quality/optimisation requirement, but when using asset store assets this isn’t the case so build sizes can really blow up.

This max texture size in the pic above , where exactly is this setting , i cannot seem to find it in project settings, preferences, details or world settings?

@ razmaz51

Did you ever figure out where those compression settings were. I can’t find them either?

Those settings are sitting in each texture details panel, just double click a texture and you will see them.

Just wanted to say, this still doesn’t have a solution unfortunately.

To clarify Maximum File Size setting is not what I’m looking for. This will only change the texture size displayed at run-time and compiled builds.
I’m looking for a way to bulk edit actual Uasset texture size to reduce the size of an unreal project on the disk. Manually reimporting smaller versions of textures is very slow.

Hi Joe Garth,

There isn’t a way - I think the philosophy is to keep everything large until the cooking stage which is a great idea in theory.

I have a plugin on the marketplace that bulk resizes textures - it’s resizes on disk (in the projects files) so reduces the whole project:

1 Like I have the same issue as you and just found following topic:

There is a package suggested there in the solution. Looks like what we need.

It does work, but you should watch out the resolutions.

the plugin mention in that topic might not work properly if texture hasn’t loaded yet.
you will get a very blurry one somehow. I have mentioned in the plugin comment before. Don’t know if the bug has been fixed or not.

Do you konw how to fix it? I have the same question…