Reducing Resolution Scale in editor messes up actors selection in viewport

Branch: This is a ‘Binary’ build from Unreal Launcher.

Build version: 4.10.0-2758231+++depot+UE4-Releases+4.10 (running on Windows 10)

Detailed description of issue: I noticed when using for example 50% Resolution Scale in editor (when simulating a game directly in viewport) it will mess up actors selection. I assume it’s because of wrong conversion of viewport mouse click coordinates to down-scaled render buffer?
You can easily see this in editor in map “Minimal-Default” from UE4 StarterContent (although it’s not a map related issue).

Repro Steps:

  1. Open “Minimal-Default” map from UE4 StarterContent of a new project.
  2. From “Settings → Engine Scalability Settings → Resolution Scale” reduce resolution to 50%.
  3. Click “Play → Simulate” option.
  4. Now in viewport try to click to select a chair actor or table or ground and repeat this for various actors in scene. You’ll notice click selection accuracy issues. When trying to select a chair sometimes ground will get selected instead. If you change “Resolution Scale” back to 100% you’ll notice selection accuracy is ok again.

issue has a 100% repro-rate.

Hey florin,

This is a known issue with UE4 that we have in our system as UE-5401. I’ve added your information to report. We’ll let you know if we see any update or if we require any additional information. Thanks for report!

Thanks for quick feedback! Great work!

It has been two years, and this issue is more relevant now with 4k screens and a need to have a lower viewport resolution for playable framerates. Please reopen ticket, thanks in advance.