Red Screen on UE4 Scene Startup, can't display on Vive

I’m sure this is a common issue and I’m just missing something small, but we just got our Vive so this problem is new to us.

First of all, other Vive demos were perfectly fine. Hardware is great.

When I open a scene in UE4, the Vive compositor pulls up automatically. Windows changes the color to Windows 7 Basic, and the Vive displays a red screen. UE4 works fine up to this point. If I choose to “VR preview,” the Vive remains red while the UE4 screen displays the screen correctly and with the correct Vive screen ratio.

I’ve already disabled all of the Oculus plugins, and I’m running the SteamVR 1.0 plugin. Is this related to Windows changing the color scheme to Windows 7 Basic (whatever that means)?


Roll back SteamVR. It’s due to a new feature called Direct Mode for the Pre, but causes a red screen on the original Vive HMD.

It causes a red screen if window elements are overlapping the compositor window.

Hi, which version should SteamVR be rolled back to? I’m experiencing the same thing on the original Vive HMD.

You don’t need to roll back, the red screen is a warning that you have overlapping screens with the vive screen which causes the vive to refresh at the rate of the monitor which is bad as it’s really hard to dev when you don’t know what frame rate your game is actually running at. To fix this I open SteamVR before hand (that little dialog box that shows whether the controllers and base stations are connected) this will pop up with a little box above it whenever the screen is red asking if you want to make the compositor full screen, click that and it’ll fix the issue

Thanks Mitch. Out of curiosity, do you do development on the original Vive HMD? I ask because I’m getting terrible performance in Unity with the original HMD, but not with the “Pre” version.

Yeah, I still use the VDK1, Hopefully getting the Pre soon though :slight_smile: as for the Unity performance I can’t really comment just because I haven’t used it in a little while

Hi Mitch,
I have the same issue and it’s really urgent.
I have a cooked and builded windows 64 bit unreal project. it worked fine before the update…
if I start the project out of the editor it works.
but if I start it from the exe, it’s either black in the vive (in the vive mirror I can see the right corner of my scene rendering… but the rest is black and in the vive it’s all black).
or if I switch back to non-direct mode it’s red.
I also tried to start up with command-line -WINDOWED but then the vive is not starting up at all.
My specific problem is that the unreal project starts in a desktop kind a view where to select if you want to start with desktop or vr mode. and then it loads the level and enables the HMD.
in this mainmenu it’s technically fullscreen but I think the window is still overlapping somehow and that’s why it’s red.
sometimes it’s also green…
totally weird. I am a bit lost here…

thanks for any new input!

Check where your display cables are plugged in on the PC. They should all be going to the GPU, not the motherboard. Do other VR programs work? For example, does anything from Steam work properly?