Rectangular holes / missing parts?

Hi there,

I resumed a project recently I had to pause a while ago. It has 273 images and took 4,5 days to reconstruct in High Detail. The result is very good, however I have some rectangular holes. It looks as if some parts haven’t been calculated. All parts are set to enabled.


1/ Does anyone have an idea, why these holes were generated and if I can avoid them?

I had to pause the calculation several times durind the 4,5 days. My only guess is that pausing and resuming the calculation could have resulted in broken parts, but that is only a guess.

2/ As some of the figures have not enough coverage or detail from the photos, I would like to add new photos. How can I avoid to recalculate the whole model (remember 5 days)?

Any help is appreciated.

Thank you in advance.

Hi Gerrit,
It seems to be a bug as stated here:

Patches missing from mesh

From my observations its hard to tell whats the cause. I experience it when having a big number of cameras with big distance differences to the object. My Temp-Solution is:

  • Eliminate the Cameras which are extremely close completely
  • Put the »Downscale for depth-map« calculation to 2 for the closer cameras, leave it at 1 for the cameras further away.

I dont know why, but It works for me so that everything gets evened out better without holes. The Topological Resolution goes down a bit, but better than holes :mrgreen: . Positive Effect: Calculation is faster :wink:

Hi Jan,

great answer. I just started re-calculating the mesh in Normal Detail with applying your solution.

Thanks a lot. I will report the result then.



I didn’t realize you could adjust depth map setting per camera.

thanks for sharing.

But I still use High Detail for Reconstruction. So its a mix of 1 and 2 within High Detail. In »Normal« images are downscaled anyway to 2 as I understand it.

Hi Jan,

the outcome is even worse. The holes get bigger, due to Normal Detail and the whole face is gone. On the backside it is the same.



I increased the Downscale for depth-map value for the inner circle of images/cameras to 2, but I couldn’t delete the closest cameras marked as orange in the screenshot, since then I would loose the detail for the guy sitting on the fountain.

Maybe creating two projects, one with the far away cameras for the fountain and one with the close cameras for the main figure would help, but I have no time to experiment with it. And the test in Normal Detail revealed it, I need High Detail.

I fear I will have to wait for an update of RC. Needless to say that I am impatient, isn’t it? :wink:

Thanks anyway.

Hi Gerrit,
Sorry to hear that. These are similar challenges I encounter a lot. Everything is kind of fine when you have a constant distance and a linear chain of photos. But for complex geometries with occlusions and fractal detail there is no compromise in just shoot as recommended. Its just impossible to capture these details then. These holes are as I found are some model parts with an extreme drop of polys/points. Like I said I could even it out with these tricks mentioned above. But every capture scenario is different. Miloš gave me some advice to use certain settings in alignment phase:

Missing / erroneous Model Parts in HighDetail Mode

Maybe he can halp you more.
I tried your idea already with one of my complex captures to calculate the outer cameras first and then the inner ones. After that merge the meshes together. It works quite well but unfortunately it just took too long when you go for an ultimate quality (At least with meshlab, maybe there are faster tools for that…). As RC throws out solids with interpolating the holes its kind of tedious to clean these meshes by hand beforehand.

Hi Jan,

thanks for the kind reply!

You are correct, at the end of the reconstruction phase I noticed about 500 of 6300 parts with zero vertices in the console window. I was very astonished that those 0-vertices-parts took at least 1 day to calculate (with zero result, holes included LOL).


I was able to calculate this set of images in Photoscan, however with a less detailed mesh reconstruction. I like the result - apart from the holes - RC is delivering.

I’m sure Wishgranter will be able to explain but 5 days for only 273 images doesn’t sound right, a couple of hours on high detail. I’m also a little suprised by the number of parts it has made 150 mil triangles 50-100 parts I would have thought

Hi Steven,

Thanks for your comments. Yes, 4 days sounds quite long. However the images are 36MP each and, to be frank, the machine is not the youngest anymore;-) .

Yeah, a comment from “Mr.” Wishgranter would be highly appreciated:-).

These are the cameras:

Hi Gerrit Schulze
2-day customer training behind me, so no time for proper replies…

We’ve already observed it, it’s a depth map issue, and the software developers are already trying to fix it… At least for now you can you create a smaller bounding box around the cutout and reconstruct it on HIGH ( no need to calculate the depth maps ), try to change the VERTICES’ COUNT to bit higher values in another reconstruction… Or send me the dataset, if you can, and I’ll try some settings, and if it works, I’ll deliver the model to you…

Has the problem already been fixed?
I’m getting just the same results with the latest version of CapturingReality.
With ************** I don’t have these problems, but I would like to use CapturingReality (when the problem has been fixed).

Hi Antonio Caroppos

And have you set the RECONSTRUCTION REGION as mentioned in my earlier posts ?

Antonio Caroppos wrote:

… the latest version of CapturingReality…

Hello there,
the name of the software is RealityCapture (without space). The name of the company is Capturing Reality (with space). :wink:

When there were holes in Capturing Reality, the mesh was intact in ******.

The only flaw that I saw in ******* was that they didn’t allow > 477 images.

However, I really like Capturing Reality.

Can you make it so that the mesh doesn’t have any holes as in ********?

Hi Antonio Caroppos

Can you post any screenshots of the actual issue ?

OK so it is a known bug. Does anyone know what causes it? What steps can i take to prevent this? can we say for sure what is definitely not causing this? Pausing reconstruction, a glitch where the program estimates vertices for a given part then goes over that quota, cached depth map corruption, computer is too slow and the construction of said part hits some kind of time out?


I just changed the vertices limit to 10m and am rerunning reconstruction in the screen shot. it was the default of 5m before shone on the model to the right.

Hi Steven
Have you set a RECONSTRUCTION REGION prior to the reconstruction ? if not, set it and reconstruct it again, it should reconstruct the model properly…

Yeah but those results wont be in till later. I hope it will be that easy to fix. I could live with that for sure :slight_smile:

Okay, so setting the reconstruction bounds does not seem to help in my case.


Any other suggestions?