Recording with Matinee causing meshes to appear

We’re trying to record a video of our world using Matinee Movie options. Everything seems to be set up correctly; matinee plays, video records and is saved to VideoCaptures folder. But when playing the video there are objects that are not supposed to be there appearing. I should mention we are using world composition, but when every level is loaded the objects that appear in the video are not in the world. It also renders correctly when we Play In Editor, launch a standalone game or compile the game.

You can see in that pic there are multiple benches overlapping each other. There is only 1 bench in that spot in the world and we even tried deleting that bench out and the video still rendered like this. This happens every time a video is rendered out using matinees movie option.

This only happens on some objects in the world but happens every time for them.

At one point we were using a spline Blueprint for rapid prototyping that adds an object at a distance along the spline and randomize some parameters like scale. That spline BP has since been deleted, but the way the scale is slightly different on each mesh makes it look like that BP was still there and fired its construction script multiple times.

The only thing I can think of, and I’m sorta leaning toward, is that the BP was moved from one level to another (again were using world composition) and the reference to the BP was not properly deleted from the original level, but for some reason is only showing up through matinee. And we currently have no way to solve this.

We have also migrated levels to a new project and the issue was still happening.

On a slight side note, we have tried deleting all the matinees and associated cameras in the world, and the matinee still played at begin play. This was solved by restarting Unreal entirely, but even after deleting the matinee and saving the level the matinee still played.

Hey JoePshoih,

Be sure you have rebuilt your scene’s lighting and geometry whenever you delete an object. If you want to simply workaround this issue you can get the Matinee to Play on Level Load, use the ‘Movie’ button option within matinee, and select the ‘close editor when capture starts’ option.

This way your editor will close, and your matinee will begin recording as soon as you launch in Standalone. This will reduce the performance overhead the editor introduces when recording your matinee cinematic.

If you are using ‘World Composition’, within the Levels dialog window make sure you have the ‘Always Loaded’ option for the streaming method. With this active, open your World Outliner and make sure that bench does not exist anywhere else.

Let me know once you have done this, and if you need further assistance.


HI Andrew,

We were using the movie button in matinee with it playing on level load when we got this problem. It’s strange but that is the only place this shows up. It’s not in the editor with every level loaded, it doesn’t show up in PIE or when launching a standalone game (Even with the matinee set up the same and playing at start), which should launch the exact same game as playing from the movie option in matinee from what I understand. But we add a matinee, add a camera and give it a track, add a director group and set it to play on level load, and then use the movie button in the matinee and we see this every time.

We were able to get a workaround by literally moving everything in the world into a new level without world composition enabled and the video rendered just fine; just one bench like there should be.

I’m not seeing the ‘Always Loaded’ option, but I don’t think that would be the problem since it isn’t in the world any other way we launch the game.

(Don’t think I mentioned this earlier, but we were seeing this duplication consistently on several objects in the world, not just this one bench)


Well that is quite interesting, but I am glad yall found a workaround. You do want to be careful with world composition because you can sometimes be working in a level that is visible, but it is not the current level. Therefore those edits will be tied to the level that is the current level and you could have ended up making a duplicate.

In any case, this is not going to be reproducible on my end, but if you find a solid set of reproducible steps to make this happen again we can investigate further.