Receiving none out of phys material of landscapes

I migrated my project from 4.23 to 4.24; everything worked in 4.23.

What I want to do is asking about the physical material with a line trace at the place the character is standing. Steps is an audio actor, Surface an array of all possible physical materials. Self is my player character.

Weird thing: it does not repeat the default physical material (which is assigned to every material by default) or that it could not have been found; it repeats none.

In the release notes of 4.24 I found at the sector landscape a point which says: “Bug Fix: Fixed an issue where landscape simple collision was returning incorrect physical material.” Could that be the problem epic hasn’t fixed and made it even worse?

I should also mention that this bug is reproducible and only with landscapes. The phys material has been identified with the layer info in the past. I also tried setting the physical material somewhere else, but it always repeats none in find… (none is a number itself); but if it’s a “real” none, shouldn’t it be an error?

Maybe someone has indeed the same problem or found a solution for that, that would be very helpful. Thanks in advance! Johann Muhl


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


I have the same problem. Happened after updating the engine to 4.24. Haven’t found out why yet though.

Upgrade to 4.24.2, that should fix the issue.