Download

Realtime painting preview problem!!

Hi!

I have problem when painting the landscape, some components doesn’t show the material.

I delete it and created new one, every time a different component doesn’t show the material when painting even after building light.

What seems causing this problem?

How many textures are you using? The landscape is quite limited with how many textures you can use for it.

5 Textures.

how much should it be ?

Theoretically 16, but I can’t get it to work with more than 10 myself before I get this issue.

Remember this is textures, not layers, so it also counts specular, normal, roughnessmaps, etc.

If it’s not staying like that permanently when you paint a new layer on a component, it will only need a short moment to apply it.
Then you can paint live from there again using both layers, until you either entirely remove a layer or add another one.

Just to be clear this is my paint textures same numbers as layers.

I waited so long and didn’t come alive, I end up by removing the components that making this and put new one, but not always worked that way, I tried not to paint so much texture in these specific components to avoid this from happening.

But I still didn’t know why is doing this.

Maybe I should try it in on a new project and see!