REALLY blurred planar reflections, are they possible?

That is my question, my floor has not to be shiny at all, and I don´t want to use SSR because it´s performance hit, performance with PLanar Reflections for the floor is ok, but it seems it always deliver shiny reflections, there is no way to force a blurred reflection, I don´t care if the blur is done all at once or something similar, but I want to REALLY blur the reflections.

Is it possible?

Cheers and thanks!

There is that prefilter roughness. Try with that.

without knowing the use case I’ll ask:
why not use reflection captures?

If the floor is not supposed to be shiny then it’s not about the reflections captures, you should have a higher roughness value on your floor material. That will blur any reflections.

Hi there.

Thanks everyone for answering, i don´t knwo why, I don´t receive email notifications :stuck_out_tongue:

The floor roughness is configured in the material, but the planar reflections have their own roughness, the problem is that the planar reflections blurriness is only applied verically, so it´s not a good blurry result, it´s pretty bad and in the end it still appears shyny.

Regarding the reflection captures, because the floor is not completely blurred, just pretty blurred, but the windows of the space are pretty bright so their reflection should be in coordination with the actual windows, with spheric capture I can´t achieve that, it´s not precise enough, unless I´m doing something wrong that can fix that.

Finally the prefilter roughness with the planar reflections, is what I used, but the effect, as I said before, it´s pretty bad, and the floor still appears shiny, and it has a limit, I cannot blur as much as I want, it blurs the scene up to some point, but it is still pretty defined, not really blurred.

The specific use case is creating a high quality floor of wood with jsut the perfect reflection amount, I achieved that using SSR, but I would prefer to user Planar reflections or captured reflections, is just i can´t get those two to work correctly it seems.

Thanks for the ideas!


Could you show some screenshots so we can judge your options at hand in a better way? That would help tremendously with making the right decision :slight_smile:


OK, give me some minutes to load the project and I´ll upload two examples, the SSR and the Planar reflections one, those are the two I applied right now.

Here you have :slight_smile:

The left part of the picture is the SSR result, the one I want to achieve with planar reflection, the right side is the maximum blurriness I get with planar reflections… pretty different result :stuck_out_tongue:
After looking the code it’s obvious that prefilter only blurs toward vertical axis. To get really blurred planar reflections you probably want to set screen percentage down and add horizontal blur after vertical one. If you don’t want to modify engine code you can do horizontal blur when sampling for planar reflections.

Replace this line with code that do multiple samples and scatter reads in x axis.

Hello, came here because I am now trying to achieve the EXACT same result as Juangea. Unfortunately, the weblinks in the last response have expired, so I was left with no answers. Does anyone know how to achieve this result that Juangea is showing?

the web links still work, you just need to be logged in to GitHub and be subscribed to the UE4 repo

Oh, you’re right, I just got access to it, thanks for the tip!

On the other hand, however, in regards to the subject of this thread, I guess I was expecting something… easier!.. I don’t quite follow what exactly needs to be replaced with… I found both files in my computer (PlanarReflectionShaders.usf + PlanarReflectionShared.ush), but I can’t quite understand what needs to be changed in which one of the two files…?

In any case, I may be wrong, but the way I’m seeing the parameter “Prefilter Roughness” works, it is not going to achieve the effect we’re talking about just by adding a horizontal blur. Not only is Prefilter Roughness locked to a maximum of 0,04, which seems to be an extremely low value, the effect it creates also seems to be homogeneous, as in, it blurs the entire reflection as a whole, not having into consideration how far from the surface the reflected element is (I expected to see something like raytraced reflections…? As seen in this video - timestamped: :frowning: Besides, lowering the other mentioned parameter “Screen Percentage” just seems to pixelate the reflections, taking image quality away :frowning:

Is it possible to achieve the result seen in the video I linked? If so, how?


I went ahead and researched a bit more about the recently released raytracing features for the engine… Apparently NVidia have just release the drivers for the GeForce 10 series graphics cards, which include support for DirectX Raytracing (DXR). Along with it, I read that Windows also needs to be updated to version 1809, so I installed that as well. And lastly, I saw on a few videos on YouTube that the engine needs to be launched through a shortcut with the instruction to open with directx12. Unfortunately, however, my Unreal project crashes soon after I open it this way - I get a crash with the following message: “Video driver crashed and was reset! Make sure your video drivers are up to date. Exiting…” I wonder if raytracing is just too heavy on the 1070 GTX, even with the newly released drivers…? :’(