Realistic lightning - HELP!!!!!

Hi all!

I just started using Unreal Engine 4 and I am trying to create realistic interior lightning for a house. I´ve been looking at several examples (Epic realistic Apartment, Koola LightRoom) how to create realistic lightning but the results are different. That is why I need some help from you guys to give me some tips and tricks how to make it photorealistic. I am posting two set of screenshots with the two methods.

Epic´s method (1,2,3): It looks okay bit it is still far from photorealistic.

Koola´s method(4,5): Too dark, and it seems the light not enters at all.

Please help me! I am suffering to solve this problem :slight_smile:

Are you sure you’ve built lighting? I’m seeing that red error in every screenshot warning you that objects are unbuilt. You need to have static or stationary lights, a lightmass importance volume, and then you Build lighting. In the World Settings, make sure you have the bounces set to a high number, the indirect lighting quality set to a higher number, etc. It looks like most of your lighting comes from dynamic or otherwise direct lighting that can’t provide the soft shadows and global illumination that a lightmass build can offer.

Hi Futurerave, I’m trying to achieve realistic results too (with loooot of difficulties).
What StephaBon said, seems right: that viewport message reports the needs of rebuilding the light, can you post new screenshots with the light rebuilt?.
One thing that it’s lot importat (one of the most) are shadows, your scene (all shots) lacks completely of shadows (except for the ones created from the directional light…generally this is due to the excessive injection of light into the scene.
I found, but I tested only in one scene so it needs to be confirmed, that stationary light with the option of “use ray traced distance field shadows” gives better results on shadows and how ligt diffuses (lights are pointing inward the scene like “realistic interior”, even if they are set as static) but, as I told before, this must be confirmed (maybe depends on the kind of scene).
keep testing with the illumination and post the progress :o
Cheers, Paolo

Hope that somenoe more skilled can give some other useful suggestion.

Thank you for the fast replies and the suggestions :slight_smile: I rebuilt the lightning and here are the results. Also I am sending the setup what I am using for the scene, maybe with that you could give me some suggestions. For the scene all surface has Lightmap resolution of 4. If I increase it it the shadows looks awful. I hope with this you could help me the find the problem :slight_smile: In my scene all lights are static just the skylight is stationary

world settings2.JPG

I’m really too new and unfamiliar with Unreal so most of the time I use the method (totally wrong) “trials and errors” :o …because there are tons of parameters that, even if displayed and adjustable, they effect the scene only if another option is enabled.
I’ts so confusing ( don’t know how so many people that are new with unrealengine can produce such photoreal scenes :confused: …maybe in a couple of years I wil be able too :wink:
If you want you can send me your scene so I can try to make some illumination test on it, then I can send it back (if I reach a nice result) with all the parameter setted.
Cheers, Paolo

You should download the Lightroom interior demo (learn tab in the ue4 launcher). It was made by Koola and the lighting is really good. It’s even possible to enhance it pretty easily. It’s a good start to learn! Berlin Flat is another scene you can download on the Marketplace, it was done by Arch-Viz specialists XOIO. Again, good lighting and materials.

I also downloaded all of them, but when I tried to reproduce it in this scene you can see the results are not the same. Did I made something wrong?

Have you looked at your Global Post Processing settings? Try and match those up to the free demos mentioned above. These can make a ton of difference to how a scene looks.

Also, how are you rendering your lighting? Have you manually adjusted your lightmass configuration? Are you building the lighting at the maximum (production) setting?

Have a read of:

Also, consider putting in some spherical reflection captures on things that should be reflecting nicely.

I think it’s worth saying that half of your battle might be in your texture selection too. A lot of those materials feel a little bright/over saturated and not to realistic themselves. A lot of what made Koola’s work great was his texture selection, color pallet and the LUT he created for color correcting.

Also, it can be very helpful if your trying to come to grips with your lighting. To replace the materials in your scene with a basic “clay render” material. Just a nice medium grey. Work out your light bounces, start working the resolution of your lightmaps up as needed. You’ll be able to bake a little quicker and most importantly you can judge the color bounce and light map quality alone. Then start adding your materials slowly one by one. It easier to get a few materials to work well together color wise than it is to have to go back and re-tweak the entire scene.

Don’t forget to place some reflection capture actors in your scene. If you have just one outside the house, the interior will reflect the outdoors and it will look wrong.

Mhh some of your models seem to have lightmap problems (bed for example).

For some reason it seems as though nothing on the inside is casting a shadow. I’m not sure exactly why that would happen, but I do see a seam next to the door on the floor in the bedroom scene. Use world space maping to keep the floor textures seamless. On that same seam it looks like three is also a shadow/lighting seam between two meshes…something I haven’t figured out how to prevent either without joining the meshes.

Reduce your spots and lightning inside to test. Something seem wrong with Indirect lightning intensity.
Are you using a fresh project, or are you using an existing one? Koola pimped the ini, so far as i know, dunno if that make problems if you use his template/build.

Look at couch and these tiny chests near bed, there are shadows.

Thank you very much for your tips and feed back :slight_smile: In the last few days I tried to make a new project and experiment with the lightning. I used the Koola´s lightroom project as a basis to create my project and the results are much better :slight_smile: I still have some question´s regarding the lightning because when I put some furniture inside the scene is getting much darker. If you could give me some advice why it could be that would be great :slight_smile:30de4c3aff0fa6df9dfcdabb6dd2ec901dc6de43.jpeg65bf798dec7541c905775b24bd4e1021d728e928.jpeg


It still looks like the resolution of your lightmaps is too low, mainly for the walls…


Do you have a directional lightsource? What is its indirect light intensity? Usually i tweak it to 7-8. LIghtmap resolutions of the walls and ceilings i usually set it to 1024.

Yeah, I have a directional lightsource. The Lightmap resolution for the floor is 1024, the walls are 512. The inderect lightning intensity is just 1. My biggest problem is that the kitchen furniture appears too dark and I don´t know why. It seams even though I have enough light in the rest of the apartement when I put the furniture inside the whole kitchen appears dark. Any suggestions? :slight_smile:

In the last screenshot I see a lot of shiny stuff, but no reflection capture probe.
Maybe that would brighten things up a little?

Here is some of my setup. The Lightmap resolution of the furniture is 256. I hope this helps to solve the problem. Also it is very weird that the light is coming from outside is soo bright at the windows it also looks unnatural :frowning:

What if you just import your assets in the Koola’s Lightroom scene and use its setup the way it is? Maybe you’ll be able to find out what exactly is causing you trouble experimenting this method.