Real-time pixelated blur to 3d objects

Hey guys, I’m pretty new to UE but I’m on it every day trying to learn so sorry for the noobiness.

I wasn’t sure to put this in rendering or here but I was poking around in the camera and figured it might be possible to make a blueprint to make this possible?

The idea is to have a normal 3d object i.e a character but the camera renders a pixelated blur around just that character only, leaving the scenery around the character normal. Any amount of pixelation is fine but just to add a number to this question let’s just say I want a person to appear to have a 128x128 texture amount.

Any ideas? Thanks in advance.

Is something like this the look you’re going for?

If so, here’s the material graph for the PP material:

Just make sure you set your CustomStencil value on your object to match whatever value you’re feeding into your BitMask:

Ive already created the material. Can you create a short tutorial on how you achieve the one on the Video. PLEASE? :frowning:

All you need to do is create a PostProcessVolume and set the Blendable material to the post-process material you created. As long as the CustomDepth Stencil Value on your object you want to pixellate matches the value you’ve set in your material, then it should just work.

the material works fine. but when I apply it to a post processing volume under blendables it affects the entire screen. I dont know whats with the number 79 and 255 on the divide node. but I did made the customdepth stencil the same on the material and on the actor inside the map. Hopefully you can help me with this one.

you have two pictures for the material node in this post. the one posted and the one on the attachment. theyre different from each other. Ive tried them both and still not working. the one from the attachment is the one who affects the entire screen. the one you posted first is just not working on my end. PLEASE help

I dont know if its a factor to consider. but see that option checked before

RenderCustomDepthPass? the “use as occluder…”

I dont have an option like that.

Okay. First off, which version of the engine are you running? IIRC, this was originally built in 4.10

I’ve just quickly rebuilt something in 4.13, and it looks like they may have changed the way the stencil pass is configured. To get it working, I had to go into my Project Settings > Rendering > Post-Processing and set Custom Depth-Stencil Pass to ‘Enabled with Stencil’ to have the pass corrrectly render. I don’t remember when this was added, but check your project settings and see if the option is there.

The constant 79 tells the render which object you want to mask the pixel blur to. This number corresponds with the ‘79’ value for CustomDepth Stencil on the object you want to mask. You can set this to anything you like, as long as the value in the material matches the value on the object.

I’m not sure why you’re not seeing that option in the actor details pane. I’ve just checked in 4.13, and they’re all still there.

Awesome its already working haha. THanks man. I’m just wondering why the right side is more filled up than the left side of the object. you can obviously see an outline of the object :wink:

Its already workin for me anyways so I’m already good with that. but is there a fixed for that unfilled part of the object? :wink:

thanks again! Stay Awesome!