Raytracing & Render Queue Performance Issues in 4.26

Ever since upgrading to Unreal 4.26, I’ve been basically unable to use raytracing. Before 4.26 I was able to move through my scenes at around 30-40fps but now no matter what the scene is, if it has Raytracing my frames drop to less than 1 and freeze up my PC for multiple seconds at a time. Rendering has also gone from a couple of seconds/minutes to now upwards of 15-20 mins for a simple 4 second render.

I tried loading up some scenes on an old project file in 4.25 and raytracing still seems to be working perfectly fine there so it’s not a piece of hardware malfunctioning from what I can tell. I’ve had a new GPU, RAM and CPU put in and none of which fixed the issue. Also tried moving Unreal and my projects to a separate SSD in case there was some sort of reading/writing issue.

I use Unreal for rendering / filmmaking and for some reason it’s particularly bad when paired with the Movie Render Queue, I’ve tried multiple renders of the same 4 second clip using different settings on and off such as Raytracing & Cinematic Scalability and it seems when Raytracing is off the results are night and day. And using the regular movie render seems to be significantly faster.

R= Raytracing, CS = Cinematic Scalability

  • 22:43 - Movie Render Queue [R=ON] (CS=ON)
  • 18:07 - Movie Render Queue [R=ON] (CS=OFF)
  • 00:28 - Movie Render Queue [R=OFF] (CS=OFF)
  • 00:49 - Movie Render Queue [R=OFF] (CS=ON)
  • 06:28 - Render Movie [R=ON] (CS=ON)
  • 00:23 - Render Movie [R=OFF] (CS=ON)
  • 01:28 - Render Movie [R=ON] (CS=OFF)
  • 00:17 - Render Movie [R=OFF] (CS=OFF)

My PC Specs are

  • GPU: Nvidia RTX 3080
  • CPU: AMD Ryzen 9 5950X
  • RAM: 64GB DDR4-3200 G.Skill Trident Z
  • SSD: Samsung T5 1TB

I have all the latest drivers and my PC should fully be able to handle ray tracing as I’ve been able to easily handle it in the past. So I’m not sure what’s happened. Maybe there’s a console command, preference setting or compatibility issue I’m missing. I haven’t seen anyone else out there having this same issue so hopefully someone can help out as raytracing is very important to my workflow.