Download

Raytracing issues

While might not be related - I do use 4.26 preview 1

here is rendering using SSR + raster translucency + cascade shadows from sun light

here is rendering using raytraced reflections + raytraced translucency + raytraced sun light shadows

So there are few issues I’m running into, seems like atmosphere is ignored by raytraced reflection, raytraced translucency is flickering in distance when camera is almost parallel to water plane, clouds are not reflected (only cubemap is) and spline mesh component has no raytraced shadows, or reflections.

Are those issues somehow solvable by some settings or should I just avoid raytracing? If these are known problems will they be solved eventually in 4.26?

Thanks
​​​​​​​

I would take a look at a couple of settings in the Post Process Volume.
Check for Raytrace reflections MaxBounces, maybe about 3 will help.
Samples Per Pixel if you are able to can be increased a bit to help with the flickering.
Also check out the cvar r.RayTracing.Reflections.ReflectionCaptures = 1, it will use reflection capture actors in your scene to help fill in some data for reflections on the last ray bounce.

What is the material graph of the water (would you post a screenshot?)?

Are High Precision Normals activated for the GBuffer (in Project Settings > Rendering)?

Hi, it’s actually very basic metallic reflective surface with normal map.

I identified the big issue for raytracing reflections is large and very distant objects, I made those mountains as static meshes. When I make them smaller and move closer to camera it works fine. This happens to every object (big and distant) and very large reflective plane.

I tried few raytracing cvars hoping that this is some threshold setting but it didn’t work.
High precision normals are activated

It looks to me as some sort of raytracing precision issue with large numbers or something, but I don’t know.

Thanks, I’m aware of the setting but it makes no difference. It seems the mountains are reflected but lighting is black in reflections.

The reason I ask about material is there might be a setting or two that isn’t correct, is enabled/disabled when it needs to be the opposite, and perhaps a node or two that could be added to get it working right with ray tracing. One node is called RayTracingQualitySwitchReplace. The problem could also be an LOD issue, wherein zooming out at a distance transitions to a lower level of LOD that causes a loss of quality and/or specific things being rendered. Perhaps it would cause reflections to become black / darker by losing base color quality with ray tracing. In Project Settings, under the Ray Tracing checkbox, is “Texture LOD” enabled?

I’m gonna get some screenshots and post here probably tomorrow or day after as I’m doing another project currently. I’m super interested though if this can be avoided, thanks for your help so far.

Well, I’m basically trying to aid in troubleshooting by sharing what I know and think of…but it doesn’t mean I have the exact answer immediately. Not saying you’re demanding that, but I wish I could help you solve it quicker. Yet troubleshooting is simply a process of steps, and probably some backtracking between those steps. There’s lots to remember in Unreal Engine as not all of it is frequently used, so I often refer to the docs and try to put things together to get a solution or discover how things function correctly.

Well, most, if not all post process effects won´t be reflected by raytracing, since they are generated after the scene is already raytraced. Most noticeable is it, if you deal with particles: GPU particles won´t be raytraced, CPU particles/mesh particles usually will be (maybe this changes with Niagara). Now i don´t know, how you generated your clouds, but if they are generated by a post process or with the help of an transparent material, you won´t get them reflected. Well, transparent materials, we have to see, what 4.26 brings for them, but all that volumetric stuff is usually post process.

Spline meshes are also not supported until now, see:

Thanks for the info, should probably look in the docs myself before asking here :smiley:

Anyways, the clouds are made using the new 4.26 volume. Using them combined with new realtime skylight updating causes choppy reflections on “water” plane casue only the cubemap updates are reflected in raytracing. (this kinda can work still if I disable auto-update on skylight and just rely on static cubemap)

Splines not being renderable in raytracing is really bad news, but since I’m not making games I can probably stick with just using normal meshes.

Still though, a really large(kilometers) object really far(several kilometers) will reflect properly only if it’s close to the world center, and become weird and black-ish as it gets far away.
I want to create a basic scene replicating this problem and share it.
It could maybe help me understand what’s up if it’s me doing something wrong.

With this issue I don’t have a workaround, screen space reflections are absolutely horrible and reflection plane only works well on the water level and rest of the scene now has to use mostly captures or ssr. It would maybe help here to be able to include-exclude objects from raytracing so that I could either disable raytraced reflection on the water or other problematic objects, or vice-versa only enable RT on objects that really need it.

Thanks again for the help. I’ll try to post here some screens and maybe a simple scene project better demonstrating the issue isolated.

There’s an option in meshes under Rendering to enable/disable “Visible in Ray Tracing”. There’s also the RayTracingQualitySwitchReplace node, which I saw a material graph posted by a user in the forum in which it was used to switch between RT and raster for reflections and maybe translucency. A video is shown on how to set it up and shows it being used and functioning in a project, but I don’t remember what thread I saw it in lately. If I find it, I’ll post a link in this thread.